#1
I currently have a Peavey Valve King 100W tube amp. I have had it since about Jan-Feb of 2007 and I have been playing my prs se custom out of it for the past year gigging and all. All of a sudden the amp is cutting out and creating terrible tones. I just played it the other day and it was fine and now it is terrible. I don't know much about the tubes themselves but they are all still lit up so I figure they are still good. Can anyone help me get an idea of why it is reacting so strangely? Thanks alot guys!
I will stand up for myself unwaivering, with only victory to tell...
#2
tubes are prolly bad
[IMG]http://img398.imageshack.us/img398/9148/dawhip005jf4.jpg[/IMG]

Quote by SuperSamuraiGuy
Thanks for answering all my question ssguitar



JCM900 FOR SELL!
#4
they are all yellowish lit which i think has been the same since when it worked originally
I will stand up for myself unwaivering, with only victory to tell...
#5
Probably tubes. Does volume all the sudden cut and then go back to normal? Does it make popping noises? When it does this, try to look in the back at the tubes and see if you see anything goin on with the power tubes such as flickering or "shock waves" going up or down it.
Quote by Dave_Mc
I've had tube amps for a while now, but never actually had any go down on me
Quote by jj1565
maybe you're not saying the right things? an amp likes to know you care.





www.SanctityStudios.com
#7
yeah the volume is cutting in and out and the tone is bad, do bad tubes make the tone bad? And would I need all of the tubes replaced or no? How often should you change them
I will stand up for myself unwaivering, with only victory to tell...
#8
Quote by csharp1589
yeah the volume is cutting in and out and the tone is bad, do bad tubes make the tone bad? And would I need all of the tubes replaced or no? How often should you change them


Probably just the power amp tubes, I wouldn't think there's anything wrong with the preamps, but I could be wrong. You probably just got a bad set. If you bought the amp new and it's still under warrenty, I'd call Peavey and ask them to send you new ones because they shouldn't be dying that quick unless you play for hours and hours everyday and you regularly play at higher than 5 or 6 on the volume, which I seriously doubt you do.
Quote by Dave_Mc
I've had tube amps for a while now, but never actually had any go down on me
Quote by jj1565
maybe you're not saying the right things? an amp likes to know you care.





www.SanctityStudios.com
#9
No for the most part I turn volume up halfway for practice and play like a few hours every couple days and then play shows too. Thanks
I will stand up for myself unwaivering, with only victory to tell...
#10
is there any possibility it may be my pedal board or no?
I will stand up for myself unwaivering, with only victory to tell...
#12
Dude, its your tubes. You need new ones. Peavey won't cover it though, as the warranty of them is like 90 days. Still, 6 months on stock tubes isn't too bad...
#13
Quote by csharp1589
is there any possibility it may be my pedal board or no?


It could be if one of your pedals is losing power or flickering on and off and doesn't bypass, causing your signal to die, but the loss of tone to me says that you need new tubes.
Quote by Dave_Mc
I've had tube amps for a while now, but never actually had any go down on me
Quote by jj1565
maybe you're not saying the right things? an amp likes to know you care.





www.SanctityStudios.com
#14
ok well from what everyone is saying it does sound like the tubes. Now should I get all four or so new ones and what kind? I have the peavey valveking 112 combo amp
I will stand up for myself unwaivering, with only victory to tell...
#16
If you have the money, I'd suggest just doing a full retube of it, you honestly can't go wrong doing that and your tone will more than likely be better than before. I suggest JJ power tubes and Tung-Sol preamps, that's my favorite combination, but right now in my 5150 I have all JJs and the F-30 has the stock Mesa tubes.
Quote by Dave_Mc
I've had tube amps for a while now, but never actually had any go down on me
Quote by jj1565
maybe you're not saying the right things? an amp likes to know you care.





www.SanctityStudios.com
#17
how much would you say that would be just an estimate for the amount I will need?
I will stand up for myself unwaivering, with only victory to tell...
#18
Hmm for a full retube, around $100.
Quote by Dave_Mc
I've had tube amps for a while now, but never actually had any go down on me
Quote by jj1565
maybe you're not saying the right things? an amp likes to know you care.





www.SanctityStudios.com
#19
ok thanks alot man!
I will stand up for myself unwaivering, with only victory to tell...
#20
Quote by csharp1589
ok thanks alot man!


No problem, glad I could help!

Quote by Dave_Mc
I've had tube amps for a while now, but never actually had any go down on me
Quote by jj1565
maybe you're not saying the right things? an amp likes to know you care.





www.SanctityStudios.com