#1
Just got a well FREE for now....got it from a buddy that let me try b4 I buy kinda thing anyway its a Marshall G15R CD....flame on BUT you know what the tone kicks my Line 6's ass! However when I got it home I notice the the input hole is loose and can move around and when that happens hald the tone goes away! When I hold it down or up with the cable it then sounds better. So I pulled it all apart and found this is not a easy fix looks like its soldered to the panel! Tried to tighten the nut on the outside of the input but its striped! Is this this fixable or not? Now you have to relize my buddy had not played this thing for 4 years because another friend had it in between but is now moved away so he got his amp back with out testing it first..hmm so anyway like I said it does sound pretty good with my ZW guitar but that dang input jack is **** now! Dont even bother saying through it in the trash!
My Gear:

Epiphone
Zakk Wylde Custom Bullseye
Silvertone Sunburst Strat Copy
S101 Standard Black Strat Copy
Boss Distortion DS-1 F/S!!!
Arion Metal Master
Line 6 Spider III
15w P.O.S

Soon: Roland Cube 20x
#2
Just curious, what line 6 amp do you have?
My Gear:
Gibson ES-335 (Dot)
ESP LTD MH-100QMNT
Spider III 75W
Digitech Whammy Pedal
Crybaby Wah
Epi Valve Junior Half stack
DS-1
Line 6 Floor Pod (FOR SALE!!!)
#3
I've never witnessed so much overuse of the exclamation point.

To answer your question, why not just take it to your local guitar shop and get an estimate on fixing it? You don't want to mess it up any more than it is, so let a pro deal with it.
Washburn WI-64
Jackson DK2
Randall RM100C
Digitech RP200A
Digitech DF-7
Digitech Phase Shifter
Boss OS-2
Boss Bf-2
#4
hold it to a position in which it works, glue the input jack in place in(hot glue if you can manage it) and voila!
#5
well the glue idea may work however to know where it needs to be means it need to be plugged in when its apart that = shock but I just came up with a fix....what I did was plug in the cable then pull up on it to feed it through the top where the strap is and pulled it snug seems to work now...
My Gear:

Epiphone
Zakk Wylde Custom Bullseye
Silvertone Sunburst Strat Copy
S101 Standard Black Strat Copy
Boss Distortion DS-1 F/S!!!
Arion Metal Master
Line 6 Spider III
15w P.O.S

Soon: Roland Cube 20x
#7
The hot glue might work for the first few times you unplug your cable or move it around but it wont last long. An input jack can be replaced but you should know what your doing before you start to operate. Im sure the shop will charge more to unscrew what ever attemt is made that doesnt work. Im sure they would love trying to get a hot glued jack out.
#8
i wont glue it but yeah the jack needs to be replaced and is solder to the panel in side....dosent look to hard at all......
My Gear:

Epiphone
Zakk Wylde Custom Bullseye
Silvertone Sunburst Strat Copy
S101 Standard Black Strat Copy
Boss Distortion DS-1 F/S!!!
Arion Metal Master
Line 6 Spider III
15w P.O.S

Soon: Roland Cube 20x