#1
Alright so I'm not sure where to put this but here seems right. I have re-stringed my guitar tons of times but today I'm running into a strange problem. I have a Jackson SL3 with a Floyd Rose classic bridge. I have all the strings on except the low e. Every time I get the low e tuned up almost to e the string pops out of the saddle. Anyone know why this might happen? I'm just hoping my bridge isn't broken. Any help?

Thanks
My Gear:
Custom Fender 62' Reissue Strat
Carvin Custom Shop DC400T
Jackson SL3 Soloist
Fender Super-Sonic 112
Boss GT-10

Quote by XianXiuHong
000-000-000-000-000
PM------------------------


You can now play every Slayer song.
#2
Make sure there isn't a piece of broken string in there stopping the saddle from gripping the string possibly.
#3
Hmm I checked that and didn't see anything...
My Gear:
Custom Fender 62' Reissue Strat
Carvin Custom Shop DC400T
Jackson SL3 Soloist
Fender Super-Sonic 112
Boss GT-10

Quote by XianXiuHong
000-000-000-000-000
PM------------------------


You can now play every Slayer song.
#4
I have the exact same problem with my jackson KVX10 ,,,, I checked the bridge from arm to saddle and locking block (or whatever their called) and theres nothing wrong with it ,,,,

just keep trying dude you'll get it in eventually its fine once its in

You think this might be sumin todo with jackson trems in general? :S
Gear:
Dean Razorback V 255 (explosion finish)
Jackson KX10 (amber sunburst)
Yamaha ERG121
random 50 quid acoustic
Randall RG50TC
#5
Yeah it might be the bridge because your guit has the exact same bridge as mine, its almost the same guitar actually, mine is just standard shaped. I checked my bridge too and it looks fine, which is why I was puzzled.
My Gear:
Custom Fender 62' Reissue Strat
Carvin Custom Shop DC400T
Jackson SL3 Soloist
Fender Super-Sonic 112
Boss GT-10

Quote by XianXiuHong
000-000-000-000-000
PM------------------------


You can now play every Slayer song.
#6
Wow,,,I had my guitar tutor and the shop I bought it from look it over at one point and they couldn't find what was wrong either, even had it happen to my tutor when he tried restringing it to find the problem ,,, still couldn't find owt wrong, he reckoned it was "questionable workmanship" on jacksons part"

(p/s ,,, please lets not have any of those licensed FR's are crap posts btw to anyone whos thinking of saying it ,,, those annoy me)
Gear:
Dean Razorback V 255 (explosion finish)
Jackson KX10 (amber sunburst)
Yamaha ERG121
random 50 quid acoustic
Randall RG50TC
#7
Yeah well I guess I may as well ask if anybody else has had the same problem, and if so how did you fix it?
My Gear:
Custom Fender 62' Reissue Strat
Carvin Custom Shop DC400T
Jackson SL3 Soloist
Fender Super-Sonic 112
Boss GT-10

Quote by XianXiuHong
000-000-000-000-000
PM------------------------


You can now play every Slayer song.
#8
Just wanted to post to say I fixed the problem by changing the bridge out. I had a spare floyd rose single locking tuner (balls can stay on the ends of the strings) sitting around from an old guitar and installed that. The action on my Jackson SL3 soloist feels better than ever. Seems they put cheap bridges in them.
My Gear:
Custom Fender 62' Reissue Strat
Carvin Custom Shop DC400T
Jackson SL3 Soloist
Fender Super-Sonic 112
Boss GT-10

Quote by XianXiuHong
000-000-000-000-000
PM------------------------


You can now play every Slayer song.
#9
Hey guys.

I have this problem with my maverick X-1.

if it is the bridge...

will any floyd fit in the space the stock one is in now?

ta