#1
Is it possible that my pickups preamp is destroyed couse i was so damn stupid to solder minus to pluss and vise verse on the battery when changing pickups?
And is the capacitor polorised so that it may also have died?

I do get sound from them, but it is crappy, i also cant change the tone.
The voltage to the pickups is at 9V as it is supposed to be.
I could not read the output voltage of the pickups though.

The pickups are EMG 81/89.

And if you do know more about what a pickup and preamp is made of that would also help.

Someone please help me, its not fun to play anymore.
#2
just re-solder the ends...
gear?
coming soon... parker fly mojo flame
ibanezes: rg350dx frankenstein * rg7620 7-string
fenders: telecaster plus * stratocaster plus

line 6: pod xt live * ax2 212
other: laney vh100r * mesa dual rectifier * monster cables
#5
Quote by psychotim
so it isnt like i could have destroyed the pickups in anyway?

you could have. flip the wires and hear how it sounds. if it still sounds f'ed, yes. if it sounds good, then great.
gear?
coming soon... parker fly mojo flame
ibanezes: rg350dx frankenstein * rg7620 7-string
fenders: telecaster plus * stratocaster plus

line 6: pod xt live * ax2 212
other: laney vh100r * mesa dual rectifier * monster cables
#6
not that long. a few minutes or something while i tryed to get some sound out of them with the screwdriver.
#7
but even though i have destroyed the pickups, why does the tone knob not work?
the capacitor isnt marked, so i doubt it is polorised and therefore is working.
So i guese there is something other that is wrong in there to, but that aint that important, couse that dont cost much and do tolerate the current going the other way.
Also i cant think of anything in a pickup that dont tolerate that the current is going the wrong way. but the preamp is another thing, dont know about that.
#8
Yeah, whatever is in the pickup's preamp, whether it be transistors or op-amps, is not going to be too friendly to the current if it's in the wrong direction. The pickup itself is most likely still functioning, only the preamp is blown.