#1
Ok so i'ver been working on a rangemaster clone form this site http://www.musikding.de/product_info.php?cPath=52_122&products_id=618
for the last few days. I'm finally finished it and everything seems to be working except there is a LOT of noise, i havn't put it into the enclosure yet so i assume this is contributing to the noise but there really is a lot. Do i just need to ground it somehow or could it be a result of bad soldering?
MIA Fender Strat
Yamaha FG-450S
Crafter 12 string
Orange Rocker 30 combo
Vox AC30CC2
Epi Valve Junior
Fulltone Clyde
Danelectro Free Speech
T.C. Electronic Vintage Dual Distortion
Boss MIJ GE-7 (c1987)
Boss TU2
MXR Phase 90
Artec delay
#2
Well having it out of the shell will increase the noise. Are you using a battery or an adapter?

Glad you got it working by the way
#3
Quote by Whole Lotta Led
Well having it out of the shell will increase the noise. Are you using a battery or an adapter?

Glad you got it working by the way

Thanks, turns out i had the stereo input wired the wrong way round. I'm using an adaptor. I can't wait to get it in the shell and painted up! I'll have pics up as soon as it's finished
MIA Fender Strat
Yamaha FG-450S
Crafter 12 string
Orange Rocker 30 combo
Vox AC30CC2
Epi Valve Junior
Fulltone Clyde
Danelectro Free Speech
T.C. Electronic Vintage Dual Distortion
Boss MIJ GE-7 (c1987)
Boss TU2
MXR Phase 90
Artec delay
#4
If you can, try it with a battery and see what happens. If you're using an unregulated power supply (it's not uncommon for some adapters to be putting out more than 9 volts) it can add a fair amount of noise.
#5
Well it's a Boss adaptor so it is regulated. But ya i will try it with a battery.
MIA Fender Strat
Yamaha FG-450S
Crafter 12 string
Orange Rocker 30 combo
Vox AC30CC2
Epi Valve Junior
Fulltone Clyde
Danelectro Free Speech
T.C. Electronic Vintage Dual Distortion
Boss MIJ GE-7 (c1987)
Boss TU2
MXR Phase 90
Artec delay