#1
Okay, so my boss distortion pedal (orange) just stopped working yesterday, and I have no idea why. I went through the things that you can do to cause malfunctions and I'm pretty sure I didn't do any of it. It says return to retail for service if it breaks, but my retailer is musiciansfriend. The problem with it is the red light turns on saying that it is activated, and the sound still goes through it, but it doesn't put any distortion into the music, even though I have distortion turned all the way up.
Anyone have any ideas on what I should do, or exactly what's wrong?
#2
Does it let sound pass through when it's bypassed? If so, where is the Level knob set?
#3
Quote by Stumpflower
Okay, so my boss distortion pedal (orange) just stopped working yesterday, and I have no idea why. I went through the things that you can do to cause malfunctions and I'm pretty sure I didn't do any of it. It says return to retail for service if it breaks, but my retailer is musiciansfriend. The problem with it is the red light turns on saying that it is activated, and the sound still goes through it, but it doesn't put any distortion into the music, even though I have distortion turned all the way up.
Anyone have any ideas on what I should do, or exactly what's wrong?

Could be that the clipping diodes were blown? idk though
OMG!!! They're playing One!!!!!11fade to black11one11

God & Founder of UG Electronics


Electronics God of the Laney Cult

My Gear:

Ibanez RG370DX
Laney VC30-212
Dunlop Crybaby
Boss CS-3
Ibanez TS9DX
#4
Quote by Denthúl
Does it let sound pass through when it's bypassed? If so, where is the Level knob set?

I always have the level set half way, and when I turn the level off, sound still passes through. It's like the settings are being completely ignored and the pedal is like an extended cord
Music: Alternative/Hard Rock/Guitar Virtuoso
Current Budget: $300
Gear:
Schecter C-1 FR Hellraiser
Peavey Valveking VK 100 Amplifier
Boss/DOD Effects Pedals
#5
Quote by Stumpflower
I always have the level set half way, and when I turn the level off, sound still passes through. It's like the settings are being completely ignored and the pedal is like an extended cord

could be a short from in-out, but it seems unlikely that that would happen, I'd take it in to get someone to look at it for you, we can't really do much on here as we can't test it etc.
OMG!!! They're playing One!!!!!11fade to black11one11

God & Founder of UG Electronics


Electronics God of the Laney Cult

My Gear:

Ibanez RG370DX
Laney VC30-212
Dunlop Crybaby
Boss CS-3
Ibanez TS9DX
#6
okay, but I don't really know where I should be taking it. I guess I'll just use my ibanez pedal for now
thanks mucho.
Music: Alternative/Hard Rock/Guitar Virtuoso
Current Budget: $300
Gear:
Schecter C-1 FR Hellraiser
Peavey Valveking VK 100 Amplifier
Boss/DOD Effects Pedals
#7
I don't know how likely it is, but a short directly between the input and output jacks could do that.
#8
Well, if it is still under warranty and you have your receipt, you could take it back to wherever you got it, I guess. Would be the best way to go about it.