#1
so a few weeks ago my friend purchased a 5150 head and 6505 cab.. he got it and we noticed it sounded like ****.. i made a post about it here and people said tube problem.. sure enough it had fender tubes and other bad tubes.. so he got it fixed and just got it back...
it sounds almot the same as before.. still ****ty and lacking... ive heard 5150 sound alot better...
so i dont understand why it still sounds ****ty.. hes tone deaf so he thinks it sounds better.. but i can clearly here the same thing?

what could be wrong wiht it?
#2
Sell it to me XD Please.......

prob a bais problem try biasing it properaly i was told if u bias them hotter they soud better
and also the 5150 / 6560 cabs arn't great
#4
hahaha, if it was my amp i probably would since this impression has been ****ty..
ill look into the biasing..
#5
Biasing could be it.
Also, power transformers.
How loud did you have it? It's likely to sound crap at low volumes - it is a gigging amp.
Quote by Skraeling86
That's a lot of booze. Frankly, I'm impressed. You're of a stronger timber than the average man, jimbob! Hail you.



Quote by Bubban
Yes you should go to a doctor, fucking moron. We can't do anything about your hemorrhoid.


#6
ive heard it sounds ok at low voulmes.. harmonic acheivable at low volumes.. his wouldnt get a harmonic to save its life.
#7
Try cranking the preamp volume, and leaving the master really low. Just throwing that our there.
My Gear:
-Schecter C-1 Plus (Vintage Sunburst)
-B-52 AT-212 Tube Combo
-ZW-44 Zakk Wylde Overdrive
-Digitech RP350 Multi-Effects Pedal
-Hamer Slammer Strat Copy
#8
Quote by jimbob78
Biasing could be it.
Also, power transformers.
How loud did you have it? It's likely to sound crap at low volumes - it is a gigging amp.

It's a 5150, it's supposed to sound good at low volumes too.
RIP Jasmine You.

Lieutenant of the 7-string/ERG Legion

Quote by FaygoBro420
Yo wassup, I'm trying to expand my musical horizons if you know what I mean, so can anybody reccomend me some cool Juggalo jazz?