#1
Ok, to start
I'm sorry if this is a common problem that is asked repeatedly, but a quick search has yealded no results :/

Anyhoo, I have an Ibanez (RG350DX) which until about half an hour ago has been good as gold for the year or so I have owned it. But all of a sudden, upon plugging into my amp I get this harsh hissing noise and a worrying cracking noise when I depress the term arm
The hiss stops/quiets down as soon as I touch the strings or any hardware in contact with them. Its deffinatly not my amp or too much distortion as I get the same problem on clean also. Nor is it any lead. If tried all my leads and both my amps and its still there.

I also plugged in my razorback with all my equipment and that things quiet as a mouse when left untouched with gain on full whack.

So its definatly my guitar...
I did tune it down half a step yesterday and tuned back up to standard... If that's of any help in isolating the problem...

But yeah, I bring my dilemma to you guys on the boards
so if anyone knows a cause and solition I would be incredibly grateful =]

-Autumn
#3
Check your lead...
Unscrew output Jack and check wires.
Unscrew amp input jack and check wires.
Other than that i dunno
"Like a midget at a urinal, I was going to have to stay on my toes"

"Like a blind man at an orgy, I was going to have to feel my way through"

#5
unscrewed the back and all the wires and solder is fine
but I'll open up my jack and see if that's ok
#6
Handy thing for rear routed guitars, just quickly check the back, isn't teh case with Strats xD
/CENTER]
#9
Quote by Autumn Offering

The hiss stops/quiets down as soon as I touch the strings or any hardware in contact with them.


this can be accredited to insufficient ground.
Gear nut
#11
make sure there is a good solid connection from your pickup ground to the body of the guitar and any other black wires inside there. when you touch the hardware or strings of your guitar you act as a ground for the circuit, cancelling a lot of the noise.
Gear nut
#12
Ahhhhh problem solved tone pot had twisted and it was surging against the side
probably a grounding issue like mrryan said =]
thanks for the help guys

-Autumn