#1
Got my new ValveKing 112 in the mail today. I've owned one before i got second hand but had to sell it for rent. My tax return got me a new VK112 from musiciansfriend. I plug my new vk in and start to smell a burning electronic smell a few minutes later when i went to hit standby.

I looked at the tubes and they were glowing red and smelled like hot electronics. I figured it was just the tubes heating up for the first time.

I played through it for about 2 minutes and then it turned off.

Guess i must have got one of those poor quality control VK's i've heard about.

Oh well, warranty here i come.
Peavey VK112
Fish&Chips EQ
Ibanez TS9DX
Jackson Warrior JS30 upgraded EMG 81/85
Epiphone Silverburst 1966 Reissue G-400
Washburn D12N

Playing since 03-11-07
........Uber Noob Skillz
#2
Hmm. Sorry I'm a noob so Im probably wrong

Probably it got banged around in shipping, which ****ed up the tubes, the tubes all had a massive overheat and ****ed up the circuit or something along those lines? XD
Epiphone G-400
GFS Crunchy PAF - Bridge

DigiTech Bad Monkey
iSP Decimator

New Amp Fund: Depleted
#3
check the fuse
Washburn D-12
Ibanez RG
Ibanez RG 7321
Epiphone Les Paul / EMG 81 85
Fender MIM Ash Stratocaster
Digitech Whammy
Small Stone Phaser
Boss SD-1-Modded
Boss MT-2-Modded
Boss CE-5
Boss DD-3-Modded
ISP Decimator
B-52 AT-212
#4
I dunno, if my amp died like that I wouldn't be laughing.

If the tubes are red, if I recall, you should have stopped and cheked the tubes and fuse.
Peavey 5150
Mesa Mark IV
Mesa Single Rectifier (Series 1)
Fender Custom Shop Tonemaster
Roland Microcube

-Whitebox OS 1x12
-Port City OS 1x12

Digidesign Eleven RackAxe Fx Ultra
#5
Quote by Reincaster
I dunno, if my amp died like that I wouldn't be laughing.

If the tubes are red, if I recall, you should have stopped and cheked the tubes and fuse.



Wow, i feel like an R-tard now. I'm an electronics major and work with circuits almost everyday and i didnt think about checking the fuse. The first thing i tried was removing a tube to look at it, but they wouldn't come out. The fuse is blown and i dont have a 3 amp fuse atm. I'll buy one tommorow and give an update.

There could be another problem still. The amp shouldn't blow a fuse on its maiden voyage.
Peavey VK112
Fish&Chips EQ
Ibanez TS9DX
Jackson Warrior JS30 upgraded EMG 81/85
Epiphone Silverburst 1966 Reissue G-400
Washburn D12N

Playing since 03-11-07
........Uber Noob Skillz
#6
Maybe it shouldn't, but my tip is to contact the store about why it blew.
Quote by stratman_13
It's okay Gabel. You kick ass.



18watter video demo

My band

Recognised by the Official EG/GG&A Who To Listen To List 2009
#7
Quote by Gabel
Maybe it shouldn't, but my tip is to contact the store about why it blew.


They emailed me a UPS shipping sticker and said just return it. I may do that even if the fuse fixes it.
Peavey VK112
Fish&Chips EQ
Ibanez TS9DX
Jackson Warrior JS30 upgraded EMG 81/85
Epiphone Silverburst 1966 Reissue G-400
Washburn D12N

Playing since 03-11-07
........Uber Noob Skillz
#8
one thing, you might already know though, but most amps use a timed fuse, usually a time delay or slow blow fuse, not a quick blow.
Peavey 5150
Mesa Mark IV
Mesa Single Rectifier (Series 1)
Fender Custom Shop Tonemaster
Roland Microcube

-Whitebox OS 1x12
-Port City OS 1x12

Digidesign Eleven RackAxe Fx Ultra
#10
Here's an update:

I replaced the fuse and it did the same thing. I turned it off before the tubes got too hot, but i smelled burning electronics.

Chalk another one up to either bad quality control at Peavey or piss poor delivery by UPS.
Peavey VK112
Fish&Chips EQ
Ibanez TS9DX
Jackson Warrior JS30 upgraded EMG 81/85
Epiphone Silverburst 1966 Reissue G-400
Washburn D12N

Playing since 03-11-07
........Uber Noob Skillz
#12
I would return it too. I don't know what it is, but VKs have the worse reliability of any Chinese amp I have seen. Very odd. The Classic series don't even seem to have as many problems, but on the flip side I bet they don't sell near as many and thus you don't hear about it as often.

On a side note, I've read on more than a couple forums lately stories of 5150's grenading themselves at about the 10 year mark where they break and nothing will bring them back. Anyone else notice this?
#13
This is only the second time i've read a story that a valveking has blown up in a since. I know i read alot of people saying they hear they blow up constantly but i just dont see the evidence and i own one as well... and mine has worked fine...
#14
I don't think shipping has anything to do with it. Sounds like crap tubes or crap build quality.

When tubes redplate, cut the amp off immediately, do not use those tubes again, they're toast.
Major of 7 String Legion 7 > 6

Carvin DC747
Ibanez RG2228
Schecter Avenger Custom Shop
and my baby....
Gibson Explorer Studio
#15
Same EXACT thing happened to me, but I traded it back to the store before it died.
Quote by Jearl

...dont play Fender just because its Fender.

Gear:
Ibanez SZ520QM
Peavey Rotor EXP
Squier Bullet (heavily modified)
Mesa Roadster Head & 2x12 cab