#1
hey everyone. i recently purchased a 1985 Marshall JCM800 4212 combo off of ebay. when it arrived, i was very disappointed when i discovered that it didnt sound very good at all. the clean channel sounds pretty bad, it breaks up even when the volume is only turned to 1, and its not even a good break up either, it sounds like something is wrong with the speakers. if you crank it on the clean channel, it starts to sound decent, but at lower volumes it just seems like something is wrong. the distortion channel sounds amazing when the gain is turned up past 8, but before that it sounds horrible. the distortion doesnt even kick in untill the gain is turned up past 5.

the seller says that the speakers are the original ones from 1985. they are two celestion GT-75 speakers, and i was thinking that they might be the problem. i know very little about tube amps, so any advice at all would be greatly appreciated.
Gear:
Gibson Les Paul Studio
Fender MIM strat with dimarzio pups
JCM800
Egnater Rebel 30
Takamine Acoustic
tons of pedals
#3
Could be the tubes. I'd change them out b4 I worried about the speaker.
I don't give a shit if you listen to me or not
#4
Actually it sounds like a blown speaker. Try running it though another cab and see if it changes the sound.
#5
you could troubleshoot forever if you don't know what your doing. You should just take it to an amp tech and don't mess around. It's worth it to pay for a professional repair.
Sounds like the seller was less than completely honest
#6
i dont think it is the tubes, because the seller put in new JJ-EL-34 power tubes before putting it up for auction. is it probably the speakers then? im planning on taking it to a tech in the near future btw
Gear:
Gibson Les Paul Studio
Fender MIM strat with dimarzio pups
JCM800
Egnater Rebel 30
Takamine Acoustic
tons of pedals
#7
Quote by phobiafreak949
i dont think it is the tubes, because the seller put in new JJ-EL-34 power tubes before putting it up for auction. is it probably the speakers then? im planning on taking it to a tech in the near future btw


did he put them in, or did he have a tech put them in? If he did, then they may be biased wrong. Or it could be the preamp tubes.
Gear:
1965 Fender Mustang not a RI
Squier Vintage Modified Jazz Bass

Peavey Classic 50
Avatar 2x12

Profile
#8
Quote by SublimeGuitar
did he put them in, or did he have a tech put them in? If he did, then they may be biased wrong. Or it could be the preamp tubes.


yea he says its been biased with the new tubes. i guess ill just have to take it in to a tech. theres too many things that could possibly be wrong with it haha. thanks
Gear:
Gibson Les Paul Studio
Fender MIM strat with dimarzio pups
JCM800
Egnater Rebel 30
Takamine Acoustic
tons of pedals