#1
So the ON button doesn't work and YES I've checked the power cable + socket works - I tryed it on another amp and it works fine.

It's a Laney VH100R btw, and it usually all lights up when plugged in and turned on. I was playing with it fine earlier then I turned it off, switched guitars, turned it on again but it didn't work. So ofcourse I swapped back guitars and still nothing happened. Not any life in it at all. And I've barely had it for 2 months (purchased from GAk.co.uk).

All my leads work fine, the power supply works fine, the actual socket in the wall works fine as it powers my pedalboard no problem.

Any other suggestions? Or should I take it to the music shop?
#2
fuse?
and its from gak the source off ALL evil
Quote by Deliriumbassist
Antisocial Behaviour Order. A chav's equivalent of GCSEs.
#4
Quote by rancidryan
fuse?
and its from gak the source off ALL evil


What's wrong with GAK? I've got all my latest gear through em and they've been excellent for me.
#5
yea, its probably a fuse.
my gear: ibanez destroyer( with gibson 500t pickup), epiphone les paul plus,ampeg electric, marshall jcm2000 triple super lead half stack
#6
have you been using standby and what not correctly, because theres always a chance you muffed up the amp. (iv'e been playing one at a store and getting one and they work fine... as long as theyre taken care of...)
#7
sounds like a fuse on the AMP itself
MAIN GUITARS:
PRS Single Cut Trem
Ibanez PGM-301
Rickenbacker 650D
Jackson RR5
Taylor 12 String acoustic
Yamaha RBX 5string bass
MAIN AMP:
Hughes And Kettner Trilogy w/ 4x12 HnK cab
#11
Actually i could use some help here, this is how i use my tube Laney VC30 amp

First Standbye switch on for around 20 seconds
then turn power on
Play and Enjoy
Turn Power off and keep standbye on still
Turn standbye off for around 30 seconds.

Am i doing anything wrong here?
/CENTER]
#12
Quote by pl0x
Actually i could use some help here, this is how i use my tube Laney VC30 amp

First Standbye switch on for around 20 seconds
then turn power on
Play and Enjoy
Turn Power off and keep standbye on still
Turn standbye off for around 30 seconds.

Am i doing anything wrong here?


this is the order you should press the button/flick switches assuming that they start at the same position.

power>30 sec>standby>play>power+standby(it doesn't matter if you leave a gap in between or not because it doesn't have an effect.

TS: check the back of the amp and see if there's a light that's on. some amps have a fuse failure light but I'm not familiar with your amp
Rhythm in Jump. Dancing Close to You.

Quote by element4433
Yeah. people, like Lemoninfluence, are hypocrites and should have all their opinions invalidated from here on out.
#13
Quote by Tomaz24
What's wrong with GAK? I've got all my latest gear through em and they've been excellent for me.


there taking alot of indepent stores buissness away because they can do stuff alot cheaper
Quote by Deliriumbassist
Antisocial Behaviour Order. A chav's equivalent of GCSEs.
#14
this is exactly what the amp "expert at the local store told me
power for 2-3min>standby on> play>standby off>leave 2-3min> power off
my gear
Cube 30
sammick strat rip off
schecter C-1 classic diamond series
Peavey JSX combo
---------------------------------------------------------------------------
A.G.E > grunge