#1
I posted this in both of the elder scrolls threads and didn't get a reply for about six days so I'm gonna make a thread. Basically on Oblivion I became a vampire (not by choice) so I am doing the vampire cure quest and can't get past a certain point. I have given her everything except for the bloodgrass. The reason being it won't let me. The option to give her bloodgrass doesn't come up. I have completed the main story so I can't get any fresh and I buy it all at the store. I already had 3 shoots of bloodgrass but I need 2. I gave the woman everything including garlic argonian blood vampire ash etc. but the option doesn't come up so I went to the store and bought all their bloodgrass and went back and it says the same so I consulted a game guide and it says I should give her the bloodgrass. Also, I have given her the argonian blood but the objective says I should give it to her. I have tried saving and loading and going completely out of the area and coming back (by fast travel and normal time) I've tried doing other objectives then coming back to it, I've tried everything. Is this a glitch or have I done something wrong. Please help me. Btw I know there are loads of Halp oblivion threads but I didn't know what to do. Thanks.
Last edited by jakemac at Mar 10, 2008,
#4
I was thinking of just screwing it off and selling it cos it's the classic edition and buying the game of the year edition and see if they've fixed any glitches.
#7
I am not doing that again I've done way too much since then. And what is neoseeker?
#8
its a gaming website ... good for help with your sort of problem just search for oblivion when your on it and you should find help