#1
Lately when I've been on my laptop I keep getting lag spikes every 20 seconds or so, my computer goes really slow for about 15 seconds and then speeds up again. Rinse and repeat...

What the hell is wrong?

This tends to happen specifically when I'm playing runescape.

Cheers in advance!
#2
Quote by Joelieo
Lately when I've been on my laptop I keep getting lag spikes every 20 seconds or so, my computer goes really slow for about 15 seconds and then speeds up again. Rinse and repeat...

What the hell is wrong?

This tends to happen specifically when I'm playing runescape.

Cheers in advance!


I used to play runescape, and had the exact same problem. It was a virus, I can't remember how I got rid of it though. I think it was a complete restart. You could alternatively try restoring your computer by a week or so.
Currently attempting to learn: The Dissentience by Protest The Hero in it's entirety.
#3
I tried reformatting, same problem again after a couple of weeks, got AVG, Spyware search and destroy and Zonealarm on my PC and nothing has ever got through that so I doubt it's a virus. :|

Unlike the majority of UG I don't do pr0nz.
#4
Quote by Joelieo
Lately when I've been on my laptop I keep getting lag spikes every 20 seconds or so, my computer goes really slow for about 15 seconds and then speeds up again. Rinse and repeat...

What the hell is wrong?

This tends to happen specifically when I'm playing runescape.

Cheers in advance!


you answered youre own question... runescape will lag your computer terribly, and also give you viruses very easily. If you dont want it to happen anymore, stop playing.
#5
Quote by RATM forever
you answered youre own question... runescape will lag your computer terribly, and also give you viruses very easily. If you dont want it to happen anymore, stop playing.


It never used to lag at all whilst playing, this is my point. And even after reformatting I still can't seem to solve the problem.
#6
System restore?

sounds like something is leeching your RAM or cpu, try checking processes to see of any unknown programms that are taking up alot of memory or cpu
#7
Well since you formatted I'm not sure how much this will help, but check on your C:\Documents and Settings\profilename\Local Settings\Temp folder.. delete anything out of there... alot of things start acting weird if you have too many files there (not necessarily too large of files but too many in number)

I would say virus scan/defrag too but that won't do much if you just formatted...

could possibly be bad RAM....IDE/SATA controller crapping out or processor on the fritz too