#1
First of all is divebombing. When i dive, the trem pops out of place and gets stuck, I have to push it back down in to its cavity. Secondly when I divebomb even slightly my trem sticks and goes out of tune , I have then got to yank it back up to get into tune again All help would be much apprecciated
You can rest when you're dead.

User of
Schecter Guitars
Blackstar Amps
MXR Effects
#2
what trem is it?

maybe the springs are loose/ too tight
Jackson KE 3 Trans Black
Schecter C7 ATX
Siggery Custom


Axe Fx Owner
#3
its the dreaded edge III lol
You can rest when you're dead.

User of
Schecter Guitars
Blackstar Amps
MXR Effects
#4
i havent had any experiance with edge III but have you checked the springs?
Jackson KE 3 Trans Black
Schecter C7 ATX
Siggery Custom


Axe Fx Owner
#5
Is your tremolo adjusted properly, That seems really weird even for a edge3
#6
I dont think its adjusted properly at all but I'm not the biggest expert on floating trems so im not sure what to do....
You can rest when you're dead.

User of
Schecter Guitars
Blackstar Amps
MXR Effects
#9
what do I need to do to get this sorted out?!?! It's really annoying, I've checked all the FR setups threads and none have solved my problem. HELP!!!
You can rest when you're dead.

User of
Schecter Guitars
Blackstar Amps
MXR Effects
#10
Either it's me, the pic, or that trem needs to be raised.

Loosen the springs a little; the Edge III shouldn't be parallel to the body, but with the back slightly raised above it.
You've read it, you can't un-read it!
#11
The trem needs to be raised, it's set up incorrectly. You have to always make shure the edge is parallel with the body. Unlock the locks, and then tighten the screws and then tune you'r guitar to whichever tuning you need. If it gets worse, then try tightning the other direction and vice versa.

Quote by Bonsaischaap
Either it's me, the pic, or that trem needs to be raised.

Loosen the springs a little; the Edge III shouldn't be parallel to the body, but with the back slightly raised above it.



What he said. Only the base of the trem has to be parallel, the auto tuners have to be slightly diagonal to the body.
#12
The edge is parallel and the auto tuners are slightly diagonal to the body, but it still keeps happening. I think I might have to get my guitar seen to.
You can rest when you're dead.

User of
Schecter Guitars
Blackstar Amps
MXR Effects
#13
Quote by Bonsaischaap
Either it's me, the pic, or that trem needs to be raised.

Loosen the springs a little; the Edge III shouldn't be parallel to the body, but with the back slightly raised above it.



You are right, my bad

Here's a diagram TS



There are more in the FR setup Sticky.
#14
The trem is way to low, raise it up. the reason why it is popping off is because the knifedges are coming out of the groove which is really bad for them, i had the same problem. i actually have mine set up paralel, i know it is supposed to be slightly up in the back, but i have no problems.
#15
Trem needs to be raised bud. It doesnt look like an Edge 3 from the pics, maybe its just me. My RGT42 has a cosmo black Edge 3 and it did the same thing....until one day it stopped dive bombing forever . I got rid of that thing and got a JS; best thing ive ever done.

Oh and it needs to be flush with the body (the bottom plate, not the saddles).