#1
Hm. I feel like I've posted this before, but oh well.

So, I've had this laptop for a while now (since Christmas 05). It's been so long in fact that it's no longer on the Toshiba website. lol

Anyway.. I've been wanting to play WoW for a long time now, but the last time I tried it on my laptop it lagged a ton. So, since I'm at my brother's place for a few days and he's a guild leader, I decided to try out the 10 day trial of WoW, and to my surprise it was running really well. A few icons were missing, but that doesn't really bother me. But then out of nowhere, I get a blue screen of death. I restarted my computer and the error report said it was a problem with my graphics card... I've had this issue before.

I'm on a Toshiba Satellite M45-S269, which doesn't have a video card, per say, but it has an on-board graphics accelerator. Here's the specs:

Intel® Pentium® M Processor 740 (1.73GHz, 2MB L2 cache, 533MHz FSB)
512MB PC4200 DDR2 533MHz SDRAM (Both memory slots may be occupied)
15.4" Diagonal Widescreen XGA Display w/TruBrite Technology (1280x800)
Intel® Graphics Media Accelerator 900 with 8MB-128MB dynamically allocated graphics memory
100GB HDD (5400rpm) Serial-ATA (SATA)
DVD SuperMulti (+/-R Double layer)
Intel® Pro/Wireless LAN 2200BG (802.11b/g)

And now for the questions..
Should I be able to play WoW on this? I don't really think I should without an actual video card... But can't hurt to ask.
And since it's pretty much the situation, does anyone know about buying a video card and putting it in my laptop? I've tried looking before but couldn't find anything, and when I called a computer shop nearby the guy didn't know.
#3
get a mac
Quote by Jackal58
I only judge people based upon the color of their skin.


Quote by Kilty Boxers
id like to shave my balls, but i always cut myself and when i do my shaver is like om nom nom testicle skin.