#1
I have a Spider III 75 watt (i dont care if you dont like the amp)

Its been working great, but when i jam with my friends and i often use distortion. When the distortion is on, and i turn the volume a little over half way, the amp will start squealing when i play. Why does this happen? what can i do to fix it?
#3
It happens because line 6 is terrible. My spider does that too.
Quote by HuckIt
I met this chick I really liked and wanted to practice sex, so I practiced on some guy I met at a gas station...
#5
Dang. Then why do all the reviews on this website say they sound great when it can't get past half way?
#7
Quote by Slaytanic6606
It happens because line 6 is terrible. My spider does that too.


No, it happens because Line 6 Spider III"s are terrible except for practice.

Line 6 isn't a bad company, and Spider's are fine for practice, so turning the volume up is making the amp squeal. Maybe a noise gate of some kind may help.
#8
Quote by thebroken
No, it happens because Line 6 Spider III"s are terrible except for practice.

Line 6 isn't a bad company, and Spider's are fine for practice, so turning the volume up is making the amp squeal. Maybe a noise gate of some kind may help.



That amp has a built in noisegate
Just read the directions on how to use it.
I plays guitars.
#10
Actually surprizingly it's not just the Spiders fault for this issue.. A lot of amps experience feedback.. But being a Spider doesnt help either lmfao
Schecter C-1 Hellraiser
Peavey 5150
Vader Cabinet 4x12
Roland Cube 30X
Line 6 Toneport UX1
Morley Bad Horsie II