#3
Batteries dead? Cables not working? Warranty still on?

If not, you're probably best off getting a better wah pedal.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.
#4
why must everyone bash behringer? theyre good for the price so stfu.

and to ts, be more specific with the problem. please.
#5
Quote by xdeathxcorex
why must everyone bash behringer? theyre good for the price so stfu.

and to ts, be more specific with the problem. please.


yeah, they sound ok and have lots of features... but they stop working! I have owned tons of behringer gear, so I'm hardly a brand snob, but one by one my behringer products die on me, in fact, my hellbabe isn't working properly either.

And I'm extremely gentle with my gear.


TS, if you have already tried all the obvious steps, of checking the switches and connections, trying batteries and power supplies, then you are probably up the creek. Best to just buy a better wah pedal.
#6
its a behringer what the hell do you expect
Vintage V-100, EMG 81&60
Chapman ML-1

Jet City JCA20H
#7
Quote by xdeathxcorex
why must everyone bash behringer? theyre good for the price so stfu.

and to ts, be more specific with the problem. please.


No, you shut up. I'm not bashing Behringer. Their cabs are good, mixers too I guess, and some of their pedals. But their guitar amps and the rest of the pedals suck.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.
#9
Yes, i used it a few times and now it's stopped, must be broken, any of you got any suggestion for a good wah pedal in the 0-$150 range?