#1
Recently just got a Peavey Valveking 112, I think its great..but

When I turn the volume high, I get alot of crackling and feedback.

And when I switch to the lead channel, and turn the volume as high as it goes, you cannot hear it at all unless your ear is about 2inches from the amp...

Clean channel with my MT-2 sounds fine, but the feedback and the other problem bug me...

Ideas of whats wrong w/ it?
#2
which volume did you turn up on the OD channel? turn up the post-gain volume. that's the master.
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#3
Quote by oneblackened
which volume did you turn up on the OD channel? turn up the post-gain volume. that's the master.


I tried both volume knobs. I played with basically every knob on the amp but couldn't get any noise out of the lead channel.(Got some as I said, but it was very, very, faint)
#4
odd, maybe it's the tubes?
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.