#1
Got a randall RM-4 Yesterday with the RM-2/50 Randall Power amp.

I have 2 pedals. Electro harmonix memory man (delay) and Electro Harmonix Holy Grail Reverb.

It has a serial and parallel effects loop. The parallel has a mix.

I've tried the following.

guitar > RM-4 > reverb > delay > RM 2/50 and it sounds like mud

Parallel effects loop with the mix @ 50% and it sounds like mud.

Serial effects loop.

No matter what I do, when I enable the effect the sound drops significantly and sounds like crap.

Any idea what the problem is here? I've also reversed the order of the effects.
#2
Have you tried how they sound in front of the amp? They _might_ work well there. Other than that, I have no idea what the problem is or how to solve it.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.
#3
In front of the amp it sounds like you are in the middle of an empty auditorium, even with the reverb turned down to zero. Basically unusable like that.

I figured an Egnater designed product was going to be the sh*t, but maybe it's the pedals. I always thought EHX was top notch.
#4
that's wierd....when i used a marshall echohead for my RM50, it sounded best right in front of the amp....but of course i might just not of known exactly what i was doing w/ the FX loops, first time having an amp with those.
My MAIN Gear
____________
"They call him the 'Sand Spider.' -Why? -Probably because it sounds scary"
*Agile AL3000 Les Paul w/ Alnico IIs
*Randall RM50
*Dunlop CFH
*fellow LEO feel free to give a shout out
#5
I've only heard good things about the pedals really, so I'm not sure what the problem is. Try it with just one pedal at the time and see how that works?
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.
#7
Some amps effects loops are set up to run stomp boxes. Some are made for rack stuff. They have a different line level than stomp boxes. Could be your problem.