#1
Hi, i have a Fender Twin Reverb silverface 1972 and i would like to know if some other guy here have one? Because when i put the reverb or the tremolo it do a little noise. But one of my tube are dead, it is about that or not? Thanks.


sorry for my bad grammar...
#3
There are a lot of things that cause noise in silverface amps. Layout, bad resistors, bad caps... The list goes on and on. It's possible you just have a simple grounding problem and an amp tech could fix it in about 10min and you won't need to buy any parts. It's also possible that you need several resistors replaced, a new tube socket, and new filter and tone caps all around. If that is the case, you will be spending a couple hundred (or more) getting the thing working.
Not taking any online orders.
#4
If it was me I would have the whole amp gone thru. Cause once you get it back in perfect condition you will really be amazed.
Tom Anderson Hollow Classic
72 thin line tele

Barber trifecta fuzz
Mi audio Crunch Box
Clyde Wah
Barber Burn Unit
Ocean efx Texas deuce
Boomerang chorus delay
Barber ltd


1971 Pro reverb
Fender acoustasonic
Fender super champ xd
#6
Someone have put some electro harmonix 6l6gc in a twin reverb? Good tube?
#7
Quote by rnrr
Someone have put some electro harmonix 6l6gc in a twin reverb? Good tube?

Just get new tubes, MATCHED tubes. It will sound much better.
Gear:
Ibanez RG550 20th RFR
Traynor YCV50
Fender FMT HH Tele
Mesa Boogie 2ch Triple Rectifier
2 1x12 custom Theile cabs
ISP Decimator
Krank Kranshaft
Boss BF-2 Flanger
BBE Sonic Maximizer
#8
Quote by CorduroyEW
There are a lot of things that cause noise in silverface amps. Layout, bad resistors, bad caps... The list goes on and on. It's possible you just have a simple grounding problem and an amp tech could fix it in about 10min and you won't need to buy any parts. It's also possible that you need several resistors replaced, a new tube socket, and new filter and tone caps all around. If that is the case, you will be spending a couple hundred (or more) getting the thing working.


+1

With emphasis on filter caps.
#9
I put 4 new tube and now the reverb work and dont do alot of noise but the vibrato do again alot of noise (work with the speed button). I need to change the vibrato tube? Or the footswitch? Thanks.
#10
Someone know if i need to change the vibrato tube 12ax7 for stoping the vibrato noise?