#1
i searched for a while for this and couldnt find anything and im kinda in a rush so i figured id post this and see what i get.

i just got a valve junior off my friend which he modded himself. there seems to be crazy amounts of buzzing whenever i turn on an od or distortion pedal (it runs fine clean, even cranked). the buzzing is almost as loud as the guitar, but doesnt seem to be present when actually hitting a note. when i turn down the treble or drive level, the buzzing goes away, but the tone obviously suffers.

should i get a noise suppressor pedal or something similar? can anyone recommend me a cheap one that does the job?

or is there a problem with the head itself?

thanks all
Mesa F-30 - 1x12 V30
PRS SE Custom 24 (GFS Crunchy PATs)
PRS SE Singlecut (Evo/Air Norton)
1989 Starforce (GFS PowerRails)
Morley Tremonti Power Wah, TS7 (808-Mod), Pitchblack, Boss DD-3, DE FnC
#2
Im no expert, but it sounds plain broken, a pedal won't sort that out. you have been sold dodgy merchandise.
#3
If it only does it when you use a pedal then the problem isn't the amp. Could be your pedal, or a bad lead cable (perhaps you are using an instrument lead rather than a guitar lead?) but most likely problem is just that you need better shielding in your guitar.
Not taking any online orders.
#4
It's probably not the amp, if it sounds fine cranked his modding must have been fairly solid. The overdrive may just be amplifying another source of noise in the signal chain. If you're running your pedals on mains, try batteries. If you run them on batteries, replace them with fresh ones. Use different combinations of cables, guitars, pedals etc and you'll eventually narrow down the culprit to a particular piece of gear.

What parts of the amp have been modded?
#5
This is an obvious one, so I'm assuming it's not the culprit, but are you using single coil pickups?
#6
no sorry for not specifying, im using humbuckers. i will try and switch out some cables to see where the problem lies if thats the case.

mods: tone, master volume. if the tone on the amp is turned down the buzzing fades but doesnt go away, and like i said, the sounds greatly suffers.
Mesa F-30 - 1x12 V30
PRS SE Custom 24 (GFS Crunchy PATs)
PRS SE Singlecut (Evo/Air Norton)
1989 Starforce (GFS PowerRails)
Morley Tremonti Power Wah, TS7 (808-Mod), Pitchblack, Boss DD-3, DE FnC
#7
Are you using power adapters with the pedals or batteries? Where is the power for the VJR coming from? It sounds to me like you may need a power conditioner. Have you tried a different location for power.

A suppressor pedal is usually designed to kill noise when you aren't playing not when you are. It may clean it up a bit, but would likely need to be turned up so high it mute your playing.

I also have a modded VJR, and it is extremely sensitive to any kind of dirty power. The least bit of trash makes it through.

I think becasue it is such a simple design and you are already pushing it with the mod.

I assume you have tried a different tube just for grins?

Just my 2 cents.
Heritage H150 Rio Pups, Dean Soltero SL, Dean Hardtail Select with Mustaine Active Pups,
Randall RT 2/50, Peavey Rockmaster, Voodoo Labs Preamp, Carvin Quad, Rocktron Piranha, Intellifex . AVatar 2x12
Peavey Classic 30, Vox ADVT 30,
Pod X3live