#1
alright so my current amp is an ampeg ba115 combo. its always been a pretty good amp and ive always been able to get some pretty good tones from it but recently as maybe a month or so ago it just doesnt seem to deliver as much. like it doesnt seem to push as much sound anymore and the tone seems somewhat bland as well. i never pushed the amp that hard so i dont know whats up. could my amp be starting to go or could my ear just have developed a little more sound wise?
#2
It's stereo amp, and I don't think it's tube. However, for a stereo amp, it is very good. Don't plug guitar into it; just use it as hi-fi if it works.
^ heh heh

erm are the pots scratchy or anything like that? how long have you had the amp for?
Quote by Deliriumbassist
Antisocial Behaviour Order. A chav's equivalent of GCSEs.
#4
are you sure your strings are not just dead?

strings have a big impact on your tone

xx
Fender Geddy Lee Jazz
Warwick Corvette $$
Rockbass Streamer Fretless
Hartke HA5000
SWR Triad

Quote by Victory2134
I happen to enjoy every mankiss from shinhoman.
#5
i have only had it about a year and a half. its not a battery cause my j-bass is passive and it shouldnt be the strings cause i put some new ones on about a month ago (now i know that they have lost their initial brightness but they are nowhere near flat out dead). thanks for the ideas though!

and btw yes it is all solid state
#6
i dunno maybe the tranisistors going or something :S shrugs
Quote by Deliriumbassist
Antisocial Behaviour Order. A chav's equivalent of GCSEs.
#7
Something similar happened to me, I'm pretty sure it's your ear.
Millie, my Peavey Grind Fiver
Peavey BAM 210 350w combo amp
Sansamp Bass Driver DI
Modded Ernie Ball VP Jr.
Monster Bass Cable, 21'

Quote by NakedBassist
Welcome to bass, you'll f*cking love it
#8
cool. i really wasnt sure but the ear things makes sense. thanks everyone!
#9
Could do what I call a functions test on it to make sure everything is working fine.

Set everything ot the middle (even gain, volume etc).

One by one, max each knob out, minimise it then take it back to neutral. See if it does what you would expect it to do. e.g. Max gain causes distorting and volume boost. No gain = no sound.
Warwick freak of the Bass Militia. PM Nutter_101 to join

Quote by elliott FTW
Damn you and Warwickyness

Quote by ScottB
Quote by CLIFF_BURTON
gm jack knows everything
+1