#1
I have a fender hot rod deluxe tube amp and I bought it last week at guitar center. Today i was playing and all the sudden the sound started to fade from the amp and then buzz then it shut off. I tried turning it back on after a couple of minutes and it hasn't turned on since.

My questions are these

1) If you blow a tube does the amp not turn on?

2) Is there a solution to this problem I can try

I always let the amp warm up before playing so I'm not sure if its a defective amp or what

3) Would guitar center give me an exchange?
#2
yea its less than 30 days old take it back and it sounds like a power problem maybe a transistor
#3
Quote by selkies
yea its less than 30 days old take it back and it sounds like a power problem maybe a transistor


ok thanks I was really worried that i just blew 700 bucks
#4
It's not the tubes. Sounds like something more serious. This are usually sturdy amps. If GC doesn't help you that thing should have a 5 year warranty from fender.
I don't give a shit if you listen to me or not
#5
Quote by Kevin Saale
It's not the tubes. Sounds like something more serious. This are usually sturdy amps. If GC doesn't help you that thing should have a 5 year warranty from fender.


It has a 3 year warrenty for defective purposes, but I didnt know if it was defective or maybe I am just missing something here
#7
Quote by IbanezPsycho
GC usually doesnt have anny issues taking stuff back.. Just return it and dont even worry about it...



Alrite thanks for everyones input
#8
Not to seem obvious but did you check the fuse?

Simple 20 cent solution if its that.
Fender 60W Super-Sonic Head
Fender 2x12 Cabinet (Vintage 30s)
TC Electronics G Major
Boss Blues Driver BD-2 w/ Keeley mod
MXR 6 Band EQ
BB Preamp
TS-9
Jim Dunlop Crybaby Wah

American Fender Stratocaster
#9
Quote by StriferDiem
Not to seem obvious but did you check the fuse?

Simple 20 cent solution if its that.


Honestly if something popped a fuse and its in its 30 days its still getting returned... The fuse popped for a reason.....
#10
If it went this fast it doesnt really matter if its a simple fuse. Shouldnt need to start puting fuses in a an week old amp. So it goes back.
#11
sounds like a power tube shorted out and took out the fuse, like it's supposed to do. Since it's under 30 days, yeah take it back, but I would guess tubes and fuse.
"The fool doth think he is wise, but the wiseman knows himself to be a fool." - W.S.
amp clips
amp vids