#1
I'm getting an error with this mod. After the first encounter with the combine, you're supposed to leave the train station (or at least the railroad area, I can only assume and you'll see why) through some stairs. When you walk down the stairs, the game starts loading the next part, but in my case the loading message appears normally, but after a while it just jumps to the desktop and I get a message titled "Engine Error" saying "Internal driver error in IDirect3DDevice9::Present()".

I assumed, though I'm nowhere near sure, that this happened because I have a DirectX 8.1 card and not a 9 one. I read that in this case you should execute a command (exec screeneffect_dx8) in game using the console - but I can't open the console. I've enabled it and all, but it says that I should use the ~ button to open it... and my keyboard doesn't have that button. It's not the plastic key that's missing, it's an European keyboard and in it's place there's a \ button.

Any help?
Quote by primusfan
It wasn't mean, it was Portuguese.

Master Saruwatari of the Pit Samurai Pm theguitarist to join

Membro do clube Português do UG.
#2
Go into the keyboard config and bind another button for the console. Or just press everywhere on your keyboard until you find that button because it's probably there somewhere.
████████████████████████████
███████████████████████████
█████████████████████████
██████████████████████████
███████████████████████████
███████████████████████████
███████████████████████████
███████████████████████████
#3
Try pressing the ¬ button.

(Top left hand corner)

Thats like the default substitute button for ~.
Gear.

Ibanez Iceman IC400.

And Daron Malakians custom triangle pick.



Thats all you need to know.
#4
^Tried both pressing every button in the keyboard and the substitute for ~ (which in my case is a \, like I said in the first post). Neither worked.

And I don't think you can bind another key for the console.
Quote by primusfan
It wasn't mean, it was Portuguese.

Master Saruwatari of the Pit Samurai Pm theguitarist to join

Membro do clube Português do UG.
#5
how did you place the ~ in this post but are unable to do it in hl2? anyways what you can try to do is first right click on your hl2 game(not the mod but the actual game), go to properties, go to the local files tab and click on verify the integrity of the game. once its done that try again. maybe you might want to reinstall the direct x drivers(the version of your video card has nothing to do with that i used to play hl2 on a direct x 7 card). also i'd suggest going to the steam forums youll probably have better luck finding an answer there
#6
Quote by jmag
^Tried both pressing every button in the keyboard and the substitute for ~ (which in my case is a \, like I said in the first post). Neither worked.

And I don't think you can bind another key for the console.


Go into C:\Program\Valve\Steam\SteamApps\User\Half-Life 2\hl2\cfg or wherever your half-life directory is

Open the "config.cfg" with notepad then look up the "toggleconsole" line. Just change the thing in quotationmarks on the right to the bind word.
████████████████████████████
███████████████████████████
█████████████████████████
██████████████████████████
███████████████████████████
███████████████████████████
███████████████████████████
███████████████████████████
#7
Quote by ubtguitarist
how did you place the ~ in this post but are unable to do it in hl2? anyways what you can try to do is first right click on your hl2 game(not the mod but the actual game), go to properties, go to the local files tab and click on verify the integrity of the game. once its done that try again. maybe you might want to reinstall the direct x drivers(the version of your video card has nothing to do with that i used to play hl2 on a direct x 7 card). also i'd suggest going to the steam forums youll probably have better luck finding an answer there

It's a different key. The ~ key that they talk about is in the upper left corner, mine is right next to the enter button.
Did the integrity part, I'll try to run it now. If it doesn't work, I'll go to the steam forums as suggested.

Thanks for helping

EDIT: ^Thanks too, I'll try that now.
Quote by primusfan
It wasn't mean, it was Portuguese.

Master Saruwatari of the Pit Samurai Pm theguitarist to join

Membro do clube Português do UG.
#8
You can force the game for DirectX8, i do it for tf2 (horrid i know) but it makes the game run faster etc.

What you do is in Steam right click on the game you want, go to properties then click ''set launch options''.
Here you put '' -dxlevel 80'' (without '' marks).

Then click OK, you game should now boot into dx8, you can check this worked by going to options(in game) and click ''video'' then ''advanced'' and it should say something like ''hardware level Direct x 8.0'' above the software level Direct X 9.0.

Hope that helps.