#1
hi,

so i have a problem. I purchased a Roland Cube 20x today and all went very well until i decided to use a different pickup scheme(before: 5way hsh->output; now: bridge active pickup -> volume -> output), cuz my 5way switch is broken partly. so i connected it to my amp, the clean channel was fine(i got better tone, lol), but i faced serious humming on the distortion channel. So is it a problem with the output jack grounding, cos i think i got everything soldered right..
tnx in advance.
#2
wat
Bands to see before I die:
Iron Maiden
Foo Fighters
Megadeth
Reel Big Fish
Rush
Streetlight Manifesto

Gear:
Epi LP Standard
Washburn Strat
Line 6 Spider (Yes, I know it's bad)

GAS:
Ibanez RG3570Z
Digitech Whammy
#3
buy a new switch and ground your guitar properly
Quote by Deliriumbassist
Antisocial Behaviour Order. A chav's equivalent of GCSEs.
#4
You changed to active pickups?? There is more gain in your signal path now and the hum is a slight feedback from the extra gain... try a noise suppressor?
#5
no, i meant that i had the active bridge pickup even before i purchased this amp, and it wasnt humming with my previous scheme..
#6
Recheck your wiring. You may have done it wrong.
Bands to see before I die:
Iron Maiden
Foo Fighters
Megadeth
Reel Big Fish
Rush
Streetlight Manifesto

Gear:
Epi LP Standard
Washburn Strat
Line 6 Spider (Yes, I know it's bad)

GAS:
Ibanez RG3570Z
Digitech Whammy
#7
If it's a seriously louder hum to the point that u can't use u may want to reconsider if u grounded your pickups correctly. Another possibility, Cranking the gain on SS amps often results in crazy hum, why not try lowering amp gain and using a pedal?
Current Rig>>Jackson Phil Collin Signature Guitar/Ibanez Artcore>>>Modded Dunlop Crybaby>>>TS-9DXModded>>>Rat kit>>Octavia>>CE-20>>DD-7>>>Musicaman HD-120
#8
i wasn't aware you had to ground actives? the diagrams with my EMG's actually told me to CUT the grounding wire. and they sound fine.
#9
well yea, i have to ground them. if i dont ground the pickup ground-wire it goes bump-bump-bump sound, no string response. if i dont ground the battery wire, then it just doesent sound at all.
#10
well, did u fix the issue?
Current Rig>>Jackson Phil Collin Signature Guitar/Ibanez Artcore>>>Modded Dunlop Crybaby>>>TS-9DXModded>>>Rat kit>>Octavia>>CE-20>>DD-7>>>Musicaman HD-120
#11
yeah, i think. that was an grounding issue. though i still get massive humming sometimes, i think thats because of my cable, cos when i stand up with the guitar, humming is huge, though when i am sitting with it, the humming isnt so large..
#12
oh dude, get another cable! Or fix it if you know how to
Current Rig>>Jackson Phil Collin Signature Guitar/Ibanez Artcore>>>Modded Dunlop Crybaby>>>TS-9DXModded>>>Rat kit>>Octavia>>CE-20>>DD-7>>>Musicaman HD-120