#1
So yesterday I was at practice and all of the sudden in the middle of playing my amp got really quiet for about 10 seconds flashed on and off, then shut off completely and now i don't know whats wrong with it. Can someone please tell me what is wrong with my amp. Thanks
#2
Tube, or solid state... brand, model please give more info
I've bought, sold, and traded more gear than I care to admit.
#3
If it has tubes in it the tubes probably went out. Same thing happened with my Marshall
#4
its a tube mesa boogie single rectifier, and if just got the tubes replaced maybe in didnt put them in right or is one of the preamp tubes is bad and made the other ones bad? But if the tubes went bad it would still turn on wouldnt it? I mean the thing literally is off like the the light is off and everything.
#5
Try replacing the fuse, and if it goes again, either take it to a shop (i suggest this) or start pulling tubes yourself.
I've bought, sold, and traded more gear than I care to admit.
#6
It's probably the fuse. You can pick up a pack of 5 or so for like $3. If that doesn't solve your problem, then try replacing the tubes.
#7
Quote by xyoufailmex
its a tube mesa boogie single rectifier, and if just got the tubes replaced maybe in didnt put them in right or is one of the preamp tubes is bad and made the other ones bad? But if the tubes went bad it would still turn on wouldnt it? I mean the thing literally is off like the the light is off and everything.


Like other's have said - it's probably a tube and a fuse. A tube failed, blowing the fuse while it died. Fuses are cheap, and if the amp keeps blowing them when you replace them, you should change the tubes. If that doesn't help, take it to a tech.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.