#1
Hey guys,
I recently moved into an apartment building which is also partially a university residence (Dalhousie University). For the last week or so my Xbox hasn't worked, which I expected because you need to register the MAC address to get past all the University Identification etc. required to use residence internet. Convieniently the building help desk did not know anything, the computer center did not know anything, and the individual that is the head of resnet is on vacation! I eventually got through to someone who DID know and they told me they would have my Xbox registered today. Success! My Xbox finally has an IP address, BUT I still can't play. My Xbox fails the MTU test everytime! I called the same helpful individual and they can not help. There are no routers in the apartment, I hook directly into the wall. I have tried two wall connections, have unplugged all computers in my apartment while doing these tests, and it repeatedly fails. Is there anything I can do from my apartment to fix this? If not, I will have to wait until next week MINIMUM to call this vacation lady, if she even knows how to fix it, and it has been 2 weeks already. Normally I would be patient but conisdering I am paying for both Xbox Live and internet, and everyone in charge is stupid, I am starting to get frustrated.
#3
Google has been tried. I go there first before posting, but all I can find is Microsoft Help which tells me to 1. Up my MTU - which I can't with no router or 2. Unhook more then one system - I only have one 3. Unhook any computers - I already tried that.
#4
I had the same problem. It wouldn't work until I found out my mac address by going somewhere on the uni's website. Perhaps there's site on the interweb that'll tell you you're mac address. I think there's a few other numbers I had to put in as well. I don't know why it would need a mac address, not being a mac and all...

Edit: Different uni, sorry.
#5
No, MAC address does not stand for Mac as in Macintosh Computers. I know where to find my MAC address on my Xbox. I'm sorry I was not more clear, my MAC address has been registered with resnet. Registering my MAC address allows me to connect and get an IP address. I believe this is a different problem.