#1
Every time I plug in my guitar, the amp begins to hiss very loudly over the sound of my playing. Sometimes, there is no sound coming from my guitar at all. I have used three different cables and three different amps, so I know the problem is the guitar. I suspected earlier that the problem was the input jack. There is nothing wrong with my pickups. I own an Ibanez GRG170DX.

What could be wrong with it? How can I fix it?

Thank you for any help.
~3.6 billion years of evolutionary progress have led to this post~
#3
it probably is ur input jack. try jiggling it around that or turn ur volume or ur tone on the guitar down.
#4
The jack was loose earlier, but I took a wrench and tightened it.
~3.6 billion years of evolutionary progress have led to this post~
#5
there could also be a loose connection inside the guitar. it happened on my friends guitar, he had to unscrew the input jack, and solder the wire back
Epiphone G-400
Yamaha Pacifica (Mod on hold due to procrastination)
Rocktron Banshee
Marshall 10CD

Quote by geetarguy13

I've never smoked before but it looks like fun.
#7
I'll take a look inside now - will it be obvious if the wire is out of place?
~3.6 billion years of evolutionary progress have led to this post~
#8
Jenneh

Quote by TNfootballfan62
Jenny needs to sow her wild oats with random Gibsons and Taylors she picks up in bars before she settles down with a PRS.


Set up Questions? ...Q & A Thread

Recognised by the Official EG/GG&A/GB&C WTLT Lists 2011
#9
question, do you have your amp plugged in on a multi-socket with lots of other electronics, or do you have it plugged in in a room where there's a lamp plugged in somewhere?