#1
Theres one thing about recording that is commonly used and yet I still don't understand it as well as I should...

I've read though Tweaks guide on MIDI twice now and still don't understand some things.

I mostly want to know how to setup Sonar 7 Producer with my Roland TD6V module so I can trigger Session Drummer 2 and hear it as I'm playing the kit.

The 6V is a nice module and all but the sounds that come out of it are very limited and easy to be bored of IMO.

PC DAW
Sonar 7 Producer
M-audio 2496 PCI interface with MIDI
Roland TD6V drum module (MIDI "In" and "Out/Thru")

Any tips on setup of the software and hardware would be great.

Thanks
Last edited by moody07747 at Jun 8, 2008,
#2
Alright. You need to connect the MIDI "OUT" from the Roland to the MIDI "IN" on the interface.

Open Sonar, select the "Options" cascade menu and select MIDI devices. In the box that opens, there should be an option in Inputs for either your interface, or the Roland. Whichever is there, click the box.

Insert Session Drummer. In the MIDI source track in the Session Drummer folder, select the appropriate MIDI source in the same manner you would select an input for an audio track.

Now click the button next to the record arm button that enables Input Echo. It should be set to "On"


That should work!
#3
Thanks MP
I'll have that a try later today and post the results.


The thing that really confuses me about MIDI is all the settings.
Channels, GM, Local Control, Sync Modes...
I guess I just have to keep reading into it all and get used to how to set it all up.
#4
OK so I got it working...I put the session drummer in the synth rack and it puts in a midi and audio track for you. I then set the MIDI input to channel 10 and turned on my Roland module.

I am getting control of the software drums but I have a problem now....I have a small delay. It's enough to really through you off when playing...but not too noticable when testing each pad. Adjusting the "time" setting in the MIDI channel doesnt seem to fix it too much.

I have MIDI going out the module into the 2496 MIDI input and the audio out is running to the headphones. If I click the drums in SD2 on screen, there isn't any delay.
I will have to try my USB cable midi adapter to see if that fixes anything.
Last edited by moody07747 at Jun 14, 2008,
#5
Ah. You need to adjust the MIDI buffer settings to a lower setting.

GO to settings -> global -> MIDI

Adjust the number of buffers at the bottom where it says Playback until the delay is gone.
#6
....ok so I just went though a bunch of different buffer settings and TBH, really could not hear much difference...

Could it be that im using a 25 foot MIDI cable between my drums and PC?

Ill try the USB MIDI cable now and see if that works.
Last edited by moody07747 at Jun 14, 2008,
#7
I'm not sure why it wouldn't help, unless your Roland has some sort of internal source/echo setting that is causing it to send/resend twice.

How low does it allow you to set the buffer?
#8
the USB cable MIDI had no difference either...and its right next to the PC...

Sonar suggest staying at or above 200ms but will allow me to go down to 20ms

I know members at the v-drums board use EZDrummer without a problem....
but going though all the settings for MIDI in the 6V module bring up nothing that I see would cause this.

I'll have to try hooking my keyboard up and see what that does.

Same thing with the keys so that rules out the hardware like the Roland drum module.
So...its something with the PC...........
Last edited by moody07747 at Jun 14, 2008,
#9
If you could take a screenshot of both your global MIDI settings and your VSTi settings that would be very helpful as I could see exactly how you have it set up.
#11
I'll post screen shots later and yes the buffer adjustment didn't make any noticable change...even when I set it to 9000ms. It's back at 200ms now.

SH1 - Full screen (large):
http://i2.photobucket.com/albums/y22/moody07747/Other/Computer/Screen%20Shots/MIDIsettings2.jpg


MIDI buffer settings:


Im not exactly sure what VSTi settings you are talking about so if that isnt enough screen shots I have no problem taking more.
Last edited by moody07747 at Jun 14, 2008,
#12
Hmmm...

Everything seems fine, lowering the buffer size should work. If it doesn't it's probably an issue somewhere between the Roland and Sonar, maybe try contacting Sonar to see if they have any more input.
#13
You don't need to adjust those setttings MIDI settings I never play with lol... Just plug and play

Its a very simple concept MIDI is just a bunch of numbers and triggers (velocity of note... start of note, end of note, legnth of note, sustain on/off, and what note is actually played)

Software samples (like your drum program) do the rest...
#14
Oh and that delay might not be MIDI induced... make sure that your software has a low buffer rate going on... 512 works in most cases...

Click General and see what your buffer size is ... this will slow down the preformance of your computer because it has to send it back to the outputs ASAP but it should fix your problem
#15
Good point, I completely ignored the thought that it might be audio playback buffers causing this. Certaintly adjust the audio playback buffers as well under Mixing Latency. Lower the number of buffers as low as it goes (mine goes down to 2), and move the slider closer to "Fast" a little a time. Too much, and you'll overload the CPU and cause dropouts whenever you play.
#16
the strange part is if I click each pad in SD that it plays without any delays and I record audio all the time without any delays.

I will try adjust audio buffers though.

It could be that Im trying to run software so advanced on an old AMD 2.20GHz single core processor...
Last edited by moody07747 at Jun 14, 2008,
#18
Go to Settings -> Audio and adjust the mixing latency buffers from there.

I run all my stuff on a AMD single core 2.0ghz with no problems so I doubt thats the cause.