#1
Hey guys. I have an old rp300 that seemingly broke a long time ago. I haven't even really thought about the thing in quite some time, but something sparked my interest in it recently. One day the thing just wouldn't turn on. I remember trying different adapters and that didn't work. Any idea what the problem could be? It's not a huge deal if it's not fixable, but it's $150 bucks I spent a long time ago and it seems like a waste not to at least look into the problem.
#2
have you done the Reset process?

if that didn't work it may just be blown and i wouldn't try other adapters unless you know for sure you have the correct rating.

in future too put these things on a surge protected power strip to avoid it getting fried by lightening or something.

sorry i couldn't help more
#3
I'll have to try the reset thing. I made sure the adapter had the correct rating, my dad is a tech nerd and has electronic stuff lying around all over the place. And it was on a surge protector. I guess if the reset thing doesn't work then it's just fried and there's nothing I can do about it? I'm not too worried about it either way, the only reason I'm even asking is b/c my little brother asked me if he could have it b/c his amp doesn't have any distortion or anything, so if I can get it to work, I'm just going to give it to him.
#4
you can always contact Digitech.
when you say it doesn't work, you mean it doesn't power on?
i think you brought this up a couple of weeks ago but i don't remember all of the specifics.

maybe Digitech has a 'Super Reset' they can do across the internet to get it working but i doubt it. doesn't hurt to check with them as maybe it is a blown fuse or something...not sure really what all is in there except a bunch of silicone, chips and a transformmer or some kind.
#5
Quote by 311ZOSOVHJH
you can always contact Digitech.
when you say it doesn't work, you mean it doesn't power on?
i think you brought this up a couple of weeks ago but i don't remember all of the specifics.

maybe Digitech has a 'Super Reset' they can do across the internet to get it working but i doubt it. doesn't hurt to check with them as maybe it is a blown fuse or something...not sure really what all is in there except a bunch of silicone, chips and a transformmer or some kind.



This is a new problem I've never brought up before. I've managed to get the thing to turn on (had to go to radio shack to get a center positive AC adapter). But, there's no sound coming out of it though. All the buttons work fine. I can change/customize all the presets, but I can't get any sound out of it. All my cables are fine, so it's not that. Maybe the input and/or output jack on the pedal?
#6
There is no such thing as a center positive AC adapter. Polarity only applies to DC adapters. IIRC the RP300A uses a 12V AC adapter.
#7
yeah - so if you need me to read off the specs on my power supply assuming they are the same i can - and it sounds like you got it working anyway except no sound.

what about thru head phones? curious.

Also i know you can set the sound 0 - 99 (gain) to either amp or USB. i know mine is. maybe it is stuck on USB and needs to be swung back (if you even have that option).

does yours have an expression pedal as well? oh wait, no.
#8
Quote by fly135
There is no such thing as a center positive AC adapter. Polarity only applies to DC adapters. IIRC the RP300A uses a 12V AC adapter.


Mine is the older model (RP300, no A). It was made in 02. I don't know much about adapters, all I know is I took it into Radio Shack, and the guy gave me an adapter that turned it on, which was good b/c it wouldn't turn on before.

To answer the other question, there is no sound coming out of the headphones jack either. So maybe the problem is the input jack. I don't have the usb feature, but it does have the expression pedal.
#9
oh...well so i'm not saying this is gonna help cause yours is older than i thought (6 yrs) but did you run thru the exp pedal recalibration?

on mine you have to do this after a reset....doesn't take long and i dont' remember the steps.

are there any other inputs/outputs on this thing? for example if i swung the gain over to USB i don't think i would hear anything unless i was listen thru computer. i realize you don't have USB - just trying to help

unfortunately if it is the input jack i bet it would be hard to replace and not worth it but wudda i know....good luck
#10
Quote by 311ZOSOVHJH
oh...well so i'm not saying this is gonna help cause yours is older than i thought (6 yrs) but did you run thru the exp pedal recalibration?

on mine you have to do this after a reset....doesn't take long and i dont' remember the steps.

are there any other inputs/outputs on this thing? for example if i swung the gain over to USB i don't think i would hear anything unless i was listen thru computer. i realize you don't have USB - just trying to help

unfortunately if it is the input jack i bet it would be hard to replace and not worth it but wudda i know....good luck


I haven't done any of the reset steps yet, but I'll be sure to try that. The only inputs/outputs that this one has is 1 input, 2 output (left/right if you want to use stereo) a CD in for the Jam a-long thing, and a head phone jack. Other than that there's nothing. I appreciate the help man, I'll try the reset stuff and if that doesn't work, I'll probably just forget it b/c I haven't really needed it for the past 4 years since it broke, so I won't be too heartbroken.
#12
hmm..if it doesn;t work (broken) Send it to me?
BACK LIKE A HEART ATTACK
#14
Well after the reset, I still got nothing. One of the buttons even stopped working. I think the thing has just bit the dust. Oh well, it was worth a shot, I got an adapter for my Metal Muff out of it so I guess I can't complain.
#16
Yea I might do that. But if it costs any more than shipping to get it fixed, it's probably not worth it, the thing isn't that great.
#17
yeah - the new ones with AudioDNA2 and 24bit codec are not that bad

and i wasn't suggesting they (or anyone) would actually have you ship it to them to fix, only to maybe offer some other suggestion

ok. done. good luck.
#18
I sent them a message, now all there is to do is wait. Thanks for your help man, I really appreciate it.
#19
Nope, I have NO idea how to fix it, but I like to take all the broken pedals and try to revive them anyways =] AND it makes me seem like I have more money xD
BACK LIKE A HEART ATTACK
#20
Anyone know how this ended? I have the same damn problem. If anyone can help I would appreciate it....