#1
The whammy bar on my edge pro won't stay in place. I replaced the washers, it worked for about an hour. It just slides down and is loose. How can I fix this? (p.s. tried tape too, but I'm looking for a more permanent solution)
thanks
Ibanez Prestige RGA321SPB
#2
As far as I know, there Isn't a permanent solution. I was going to suggest tape, but it seems you've tried that.
#3
i have an ibanez with an edge on it, i think its a pro or edge 3, either way, look at the back of the guitar, take the cover off for the springs , read ur manual and theres a allan screw that can be adjusted for tremelo arm movment
#4
Quote by 6-string-yay
i have an ibanez with an edge on it, i think its a pro or edge 3, either way, look at the back of the guitar, take the cover off for the springs , read ur manual and theres a allan screw that can be adjusted for tremelo arm movment

I remember you could do that with an Edge 3, but I don't think you can with an edge pro.
#5
Quote by One Way Ticket
I remember you could do that with an Edge 3, but I don't think you can with an edge pro.



ya im probably wrong..
its a friggin sweet setup the edge 3 though
#6
Quote by 6-string-yay
i have an ibanez with an edge on it, i think its a pro or edge 3, either way, look at the back of the guitar, take the cover off for the springs , read ur manual and theres a allan screw that can be adjusted for tremelo arm movment

My manual says nothing about adjusting an allen screw. It just says replace washers to create stiffness in the tremelo.

By the way, tape really doesn't help too much. It just decreases the speed at which it slides down. A lot of tape renders the whammy unable to go into the socket.
Ibanez Prestige RGA321SPB
Last edited by tarlkea at Jun 12, 2008,
#7
Quote by tarlkea
My manual says nothing about adjusting an allen screw. It just says replace washers to create stiffness in the tremelo.


did all u do was replace them?
did it come with more?
cuz it sounds like all u did was put new ones in, bvut i think itd make sense if u added more?
#8
Quote by 6-string-yay
did all u do was replace them?
did it come with more?
cuz it sounds like all u did was put new ones in, bvut i think itd make sense if u added more?

they wear down after like an hour for me.
Ibanez Prestige RGA321SPB
#9
so.. wat do u just replace them or do u put more in
and if they wear out so quick .. maybe u have something too tight idk
im not farmilliar with the pro
#10
Quote by 6-string-yay
so.. wat do u just replace them or do u put more in
and if they wear out so quick .. maybe u have something too tight idk
im not farmilliar with the pro

I have no more left now. But before I put more in and replaced them.
Ibanez Prestige RGA321SPB
#12
try putting a spring from a clicky pen in the hole then put the bar in and see if that works.
#13
I have the same problem with my Edge Pro... annoying as hell, the only bad thing about the Edge Pro IMO
Tried to replace the washers and nothing happened
Gear
Ibanez RG2550E
ESP/LTD M-10
Fender FM212R amp
EHX Metal Muff
Ibanez WP-7 Wah
#14
Quote by stebbic
I have the same problem with my Edge Pro... annoying as hell, the only bad thing about the Edge Pro IMO
Tried to replace the washers and nothing happened

It's really the only bad thing i can say about my ibanez rg1570 (ignoring the stock pickups).
Ibanez Prestige RGA321SPB