#1
It's my backup amp and it's in the shop again, thats how much trouble I have with it..

I brought it in last week because the tubes were smoking, I just got it back, the receipt says..

" Removed chassis from amp, removed foreign object laying on circuit causing tubes to overheat, replaced two defective capacitors in power supply circut. $40"

Now I bring it home and turn it on, clean channel, start playing sounds fine.. Tubes are fine, lead channel no volume.. It worked before I brought it in, but not now?! Anyone know why? I don't want to bring it back he charges way too much.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#3
I've had it for a year. I have a Mesa Roadster.. It's just my backup amp and my 2nd guitarists amp and trust me I really want to get it fixed so I can stop listening to his mic'ed marshall solidstate practice amp at practice.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#4
anyone?
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#5
Quote by esp1234
Return it, and get another amp.

this
Valveking CLIPS/Gear HERE
#6
Dude I can't return it.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#7
Well sounds like the tech didnt complete the job, take it back to them and tell them to fix it... And honestly if you do get it fixed i would take it somewere and trade it off for a different amp. You might loose some cash on the deal but it will be worth it. Sounds like you got ahold of a lemon...
#8
I guess I'll have to take it back again.. I spent $400 on this shortly after it came out, and about $75 on repairs.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#9
Quote by tr3nt
I guess I'll have to take it back again.. I spent $400 on this shortly after it came out, and about $75 on repairs.


Only issue I have had with mine is one or multiple preamp tubes being busted. Replaced those and i was good to go....
#10
I'm just wondering why my clean channel works but my lead doesn't? it's odd.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#11
Quote by tr3nt
I'm just wondering why my clean channel works but my lead doesn't? it's odd.


Could be a number of things man.... Might be as simple as the dude maybe disconnected the channel switcher. Could be a tracer went out and so on and so on...
#12
Quote by IbanezPsycho
Could be a number of things man.... Might be as simple as the dude maybe disconnected the channel switcher. Could be a tracer went out and so on and so on...


Well you can faintly hear it.. Does that number it down?

faintly.. Well barely .
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#13
That's strange, I'd almost say its a preamp tube, but I would think the clean channel would be affected as well.
I don't give a shit if you listen to me or not
#14
It worked before I brought it in though.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#15
Hmm I decided to check my preamps and I noticed one preamp tube socket is loose.. Is this the culprit?
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#17
Quote by 311ZOSOVHJH
What was lodged in there originally...did they say?

Sounds like they made things worse...I would demand they fix it right at no extra charge.


Well they said a screw fell from inside the chassis onto the circuit board and shorting something out causing the tubes to overheat.

All good until I tried playing my lead channel .. I guess I'll have to call them tomorrow to see what I can do.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#18
call the tech and demand your money back or for him to actually fix it. That is unprofessional and unacceptable. And usually amps come with like a 60 day warranty or something. I think my B-52 has a 2 year warranty, and I got the extra 2 from guitar center so if anything happens to it, no matter what i can bring it in and get a new one...

living in a fraternity house can cause problems, worth the extra 50 bucks, lol. But i would definately look into that.
-------------------------------
Faded Gibson SG Special - Black ice mod
Seymour Duncan SH-5 in bridge
B-52 AT 112
Ted Weber Mass100 attenuator
EHX Small Clone
EHX Metal Muff
DIY Modded tubescreamer
Dunlop 535Q Wah
Wax Potting tutorial
#19
I've had it for a year now.
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#20
If you can hear it but barely, the extra gain tube used for the lead channel might be dead. Try and replace it.
#21
It was working completely fine before I brought it in..
Matthew 7:7 ""Ask and it will be given to you; seek and you will find; knock and the door will be opened to you."

Pop Punk! Check us out!: Flinch
#22
right, but it is possible that if they forgot to connect something back properly maybe THEY blew the tube....doesn't matter just take it back in there

dude...folks are only trying to help and i'll admit sometimes i don't read every single post within a thread sometimes too.