#1
Hey guys, im relativly new to tube amps and something has gone wrong XD. My 5150 head has stopped working. I put it on standby and it sounds like its going to work the tubes warm up as normal, but i turn the power on and nothing happens it just stays the same. It cut out on me at a practice the other day it was fine then all of a sudden just no sound came out of it.

I changed the tubes before and nothing different. Could my power switch be broke because thats all i can think of?
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9
#3
sory, a bit confused, did you go...

powerswitch: turned on (switch up) .... leave for a while... then turn the standbyswitch down to up (ie both switched up)
#4
So you're flicking the standby switch, then the power?

Do it the other way, turn power switch on, leave it, then flick the standby switch so the green light comes on.
No man has the right to be an amateur in the matter of physical training. It is a shame for a man to grow old without seeing the beauty and strength of which his body is capable


@gossage91
@overtimefitnessau
#5
Quote by lockless7x
well do u have it under warranty ?


They don't make the 5150 anymore so no
╠═══════╬═══════╣

Tap Tempo Tap Dancer of τλε τρπ βπστλεπλσσδ


╠═══════╬═══════╣


MINION of the"I drive a stick cause I'm better than you!!" Club

PM TehNez or IbanezPlayer27 to join.

EHX Users Guild. Bugera Users Militia
The MXR Lounge
#6
i no how to turn my amp on yea, it goes power to on, leave for a while switch the standby switch to on and its no different. but like i sed it died while i was playing it but it still warms up wen on standby so all power is going to it.
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9
#7
kinda a stupid question most people think about this. But it's possible it could be your cable... always the first thing i check just to make sure, hah
-------------------------------
Faded Gibson SG Special - Black ice mod
Seymour Duncan SH-5 in bridge
B-52 AT 112
Ted Weber Mass100 attenuator
EHX Small Clone
EHX Metal Muff
DIY Modded tubescreamer
Dunlop 535Q Wah
Wax Potting tutorial
#8
ive tried different cabs, different speaker cables and different guitars, even used the line out into a mixer to see.well the green light dusnt come on wen i switch the standby off. so my guess is that the power switch isnt working but it dusnt make sense to me why it would cut out while playing like that.

a fuse cant be blown because it still warms up :S i have no idea.
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9
#10
This switch flicking has me a bit baffled,

power,then standby or did you do it backwards?

the first should have done the trick but the problem could be stemming from something else...


Well hopefully you have warranty?
#12
basically the green light dusnt come on wen it is turned completly on, thats if irt can turn itself on if the switch is broke. i would take it apart and look at the switch from the inside but i have no clue how to get there its built like a fortress XD.
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9
#13
sounds like a pre amp tube, plug your guitar into your effects return, if it still doesnt work its something else
Gear
Schecter C-1 Hellraiser
Ibanez EX 470 (1991)

Peavey 6505 combo
Vox Valvetronix AD15VT
Danville 1X12 Cab
Kustom 12w tube

Dunlop Crybaby
DOD overdrive(YJM)
Boss Ns-2
PodXt
Dod 250 Overdrive
#14
well when it broke a replaced all the tubes because thats what i thought it was and it still doesnt work =[.
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9
#15
I've had exactly the same thing happen to both my 5150 AND my 6505. I was pretty lucky as I got it sorted for nothing but you gotta get it back to Peavey or a good amp tech.
I tried everything to get it sorted but I couldnt fix it, Changing tubes, fuses, leads, speaker cabs and nothing worked.
#18
hey jscustom did you find out wat was actually wrong with yours?, was it just a faulty switch or was there something wrong inside?
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9
#19
As he had it working sounds like he knows how to turn it on. And hes tried the obvious things, cables, guitar, new tubes. If TS you were running it at practice with a guitar cable connecting the head to the cab then you probably did some serious damage and if it has a ohms switch on back was it set right. If not that then its time for a trip to the shop. If all the lights are on the tubes are glowing then its gonna be something more than a faulty switch. If it was a switch then nothing would work.
Last edited by Tackleberry at Jun 22, 2008,
#20
If the cable isn't the problem, have your inputs checked out.
2008 Schecter C-1 Hellraiser
Currently amp-less!

Fund My GAS
#22
well there 2 guitar inputs used them i used the effect loop aswell to see if i got anything out of it and like i sed not ALL the lights come on the green power light doesnt come on when i turn it fully on, and no ohms was set right and that cables were the right cables.

im taking it to a shop wenever i get chance. my guess is it is the standby switch is messed as it isnt turn from standby to on.
Equips:

Ibanez RG2550E
Jackson DKMG
ESP LTD EC 200 QM
Peavey ValveKing Head & Slant Cabinet
Peavey 5150
Ashdown Fallen Angel 4x12 Cab
Ibanez Tubescreamer TS9