#1
I just got a mac and installed firefox successfully but when i go to open it the browser does not pop it just says firefox in the top right corner....I have no idea whats going on, it worked before (like an hour ago) did it crash? any help would be appreciated.
Rig:
Ibanez RG1570 Mirage Red
Fender Highway One Strat w/ 2 Seymour Duncan Hot Rails & Dimarzio X2N

Boss SD-1
Boss TU-2
Traynor YCV50 Blue
#3
Are you sure you installed it properly? I used to have a lot of trouble mounting things and figuring out how to drag the applications to the apps folder before unmounting the disk.

Oh, and try bonecho. That's what I use. It's a firefox beta for mac.
Telecaster - SG - Jaguar
Princeton Reverb, Extra Reverb
P-Bass - Mustang Bass
Apogee Duet 2 - Ableton Suite
#4
yea firefox is in the apps folder it just wont open as a browser for some reason the window doesn't pop up or anything
Rig:
Ibanez RG1570 Mirage Red
Fender Highway One Strat w/ 2 Seymour Duncan Hot Rails & Dimarzio X2N

Boss SD-1
Boss TU-2
Traynor YCV50 Blue
#5
Oh! Maybe go to file->new window? And if that doesn't work, quit the program from the dock and try again.
Telecaster - SG - Jaguar
Princeton Reverb, Extra Reverb
P-Bass - Mustang Bass
Apogee Duet 2 - Ableton Suite
#6
no all it says is firefox in the top left corner and when i click on it my only options are 'about firefox" "preferances" "hide Firefox" and "quit"
Rig:
Ibanez RG1570 Mirage Red
Fender Highway One Strat w/ 2 Seymour Duncan Hot Rails & Dimarzio X2N

Boss SD-1
Boss TU-2
Traynor YCV50 Blue
#7
K i figured it out i had to uninstall all my ad ons i must have downloaded a bad one thanks anyway guys
Rig:
Ibanez RG1570 Mirage Red
Fender Highway One Strat w/ 2 Seymour Duncan Hot Rails & Dimarzio X2N

Boss SD-1
Boss TU-2
Traynor YCV50 Blue