#1
ok so i just dropped my cell phone accidently and it landed right on the front side. i opened it up and the whole screen is white. i would post a picture but im not sure how. any suggestions?
Quote by extrememetal94
I really hope I have a small penis.
#5
Take it with your phone...


Ohh.
Quote by atr5557
i just got the boss mt-2 metal zone pedal today. i got the adapter for it but how do i know if its charging?
#6
well im trying to save the trouble of buying one. plus i dont have any money.
i was wondering if there was something i could do to fix it or something
Quote by extrememetal94
I really hope I have a small penis.
#7
Ummm well you get a camera take a picture load it to the computer and save it to imageshack.

But that sucks.

Gear
Gibson Les Paul Traditional
Carvin V3 and Marhall 1960A cab
2 B.C. Rich Ironbird Pro
Schecter Hellraiser 6
Boss ML-2

#8
Take it to a phone shop?
Use logic, my friend.
Quote by atr5557
i just got the boss mt-2 metal zone pedal today. i got the adapter for it but how do i know if its charging?
#10
Quote by KISSguitarist
Ummm well you get a camera take a picture load it to the computer and save it to imageshack.

But that sucks.

its loading it to the computer that i cant get. i usually just use my phone for that but not this time...
Quote by extrememetal94
I really hope I have a small penis.
#11
Since you ignored me, I'll try to answer anyways.

There are at least two multi connectors for the screen, one from digitizer and one to main board - so it's entirely possible screen is still receiving power but not signals from main board. That's not to rule out something more drastic but hopefully that's all it is.

Copy and pasted from another site.
#13
Quote by вяaи∂ иєw
What type of phone?


sorry.
motorola w-something
Quote by extrememetal94
I really hope I have a small penis.
#14
Quote by вяaи∂ иєw
Since you ignored me, I'll try to answer anyways.

There are at least two multi connectors for the screen, one from digitizer and one to main board - so it's entirely possible screen is still receiving power but not signals from main board. That's not to rule out something more drastic but hopefully that's all it is.

Copy and pasted from another site.

i have no clue what any of that means...
Quote by extrememetal94
I really hope I have a small penis.
#15
Quote by soccerguy6494
i have no clue what any of that means...


In that case, take it to a phone shop.
Quote by atr5557
i just got the boss mt-2 metal zone pedal today. i got the adapter for it but how do i know if its charging?
#16
Quote by soccerguy6494
sorry.
motorola w-something

Yeah, apparently it happens a lot with Motorola phones.

Quote by soccerguy6494
i have no clue what any of that means...


Well there should be two cables connecting to the screen. If there is two connected, try reconnecting them or something. You would have to take it apart though.

It'd be best to take it to a shop though.
Last edited by вяaи∂ иєw at Jul 10, 2008,