#1
my neck p/u on my LTD EC1000 has gone really weak and is buzzing alot initially i thought it needed a new battery so i put one in and it is still very weak, could this be a wiring problem? should i take it to a tech? or can it be easily fixed?
any input is appreciated.
I'd **** her so hard, even if she was a decomposing corpse... and I'd just dug her up... damn that'd be hot.
#2
By your description it sounds like it is somewhere in the wiring. Is it just the neck pickup?
#3
yeah the bridge pickup is fine
I'd **** her so hard, even if she was a decomposing corpse... and I'd just dug her up... damn that'd be hot.
#4
if it is EMGS, check the quick connect wire on the neck
My Gear
Guitars:
-Gibson Les Paul Tribute (Bare Knuckle Nailbombs)
-Ibanez "lawsuit" Les Paul (Seymour Duncan Pegasus and Sentinent)
-Ibanez S470 (Dimarzio D-sonic and Humbucker from Hell)
-PRS SE Custom (Guitarforce Black Diamond and Lord of the Blues)

Amp:
Marshall TSL100
EVH 5150III EL-34 50w
Marshall 1960a cab

Effects:
Dunlop 535q wah
Boss Super Chorus
Bogner Uberschall
Ibanez DE7 Delay
Electro-Harmonix Power Booster
Fender PT100 Pedal Tuner

Strings:
Ernie Ball Skinny Top/Heavy Bottom 10-52
#5
Could be a bad pickup, bad pot, bad switch, or bad wiring. All 3 could cause this kind of problem.

I'd start by installing checking the quick connect and make sure that is good. If you get no luck there then install the neck pickup into the bridge. That'll let you know if it's the pickup or something else.
Not taking any online orders.