#1
Bought one of these (not working) off a guy.

Checked it out and the 3.15A fuse in the back had blown.. changed it and the amp power light came on but no standby light.

Checked in the forums (as you do) and someone else had the same problem which was sorted by replacing one of the five internal 2A fuses. Sure enough one of them had blown, so I changed it.

I cant properly test the amp as I dont have any speakers yet and am aware that running it with the incorrect speakers will knacker it again (probably what the other guy did).

I turned everything to zero and switched it on.. everything seems ok apart from one of the small valves (I believe it's the preamp) isnt lighting up.

So to my questions.. can this amp be run with a dead valve in the preamp? can the amp work with one of the valves missing from the preamp? hell.. can I run it with all the valves out of the preamp?

Any info will be gratefully recieved.. cheers.
Last edited by elzorillo at Jul 18, 2008,
#2
i think, taking a valve out will just make it less powerful (taking all out will stop it working if its all valve)

thats a total guess from waht i have heard, i have no experiance.


and i dont see how running it with the wrong speaker cab would break anything..

thats just not physically possible..
*Enter Sig Here*
#3
I think it will either make no sound at all without a preamp valve, or it might make noise but the signal would be weak/lack distortion/whatever.

And please don't go around turning it on at ALL if it doesn't have speakers plugged into it.

Edit: He probably means "incorrect speakers" as in ones with too little wattage or mismatching impedance?
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.
#4
ahh, good point, although, wouldnjt that just p[roduce bad quality sound/blow speakers rather than effect the head?
*Enter Sig Here*
#5
Quote by Hale_91
ahh, good point, although, wouldnjt that just p[roduce bad quality sound/blow speakers rather than effect the head?

At first, yes. But after the speakers have blown there's no load on the amp, and the output transformer will go kazoomble on you.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.
#6
Quote by Hale_91
ahh, good point, although, wouldnjt that just p[roduce bad quality sound/blow speakers rather than effect the head?



Theres loads of posts on this forum about people plugging the wrong speakers into the head (dont know the technical name for it.. impedance maybe? the 4-8-16 setting on the back)) and blowing the fuses after five-ten minutes.
#7
AFAIK, the common train of thought in regards to turning a head on without a load doesn't matter (contrary to what I and the majority of The Pit has said before) as long as you don't put a signal through it (i.e a guitar). I'd just take it to a tech personally.
Quote by Pookie6
Yngwi3, You win this whole monstrosity of a thread.

Quote by uk.mace
For the best tingle, use Original Source mint. That shit feels amazing on your balls.


Godfather of The Diezel Mafia
#8
Quote by Yngwi3
AFAIK, the common train of thought in regards to turning a head on without a load doesn't matter (contrary to what I and the majority of The Pit has said before) as long as you don't put a signal through it (i.e a guitar). I'd just take it to a tech personally.

I guess that might be true. But I wouldn't risk anything like that with something this expensive.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.