#1
Okay, so not to long ago I got my first tube amp, a 112 Valveking. I love the amp, but when it's turned on, it makes a a wieard staticy/popy sound when I'm not playing anything. I was just wondering if it's doing this just cuase it's a tube amp, or is there somthing wrong with it?
Quote by dcdossett65
Life is too short to worry about this crap.

Who.

Cares.
#2
Possibly you have a bad cable from your guitar into the amp. Do you have others you can try? Was the amp new or used?
I wondered why the frisbee was getting bigger, then it hit me.
#3
I wanna say maybe a problem with tubes, but then again dont quote me on that as im not sure at all. All i know is that my VK made popping noises and it turns out my power tubes were failing on me.
Guitar: Ibanez Rg 2ex2/ with Dizmarzio Super Distortion
Amp: Peavey Valveking 212 (replacing soon)
Pedals: Planet Waves Tuner, Boss DS-1, Digitech DF-7, MXR-108 EQ
#4
I'm useing a brand new cable, so I don't think thats the problem...I was thinking i might have a dieing tube, but I'm not realy sure
Quote by dcdossett65
Life is too short to worry about this crap.

Who.

Cares.
#5
the sound goes away when I switch over to standby, if that makes any difference at all
Quote by dcdossett65
Life is too short to worry about this crap.

Who.

Cares.
#6
Standby kills all output to the speaker. Now, it could be a bad cable, or more likely a loose tube. Make sure the tubes are in their slots well. An outside possibly is the jack needs some contact cleaner.
#8
yeh, it still makes the sound on the clean channel, when I'm playing it gets drownd out, so I'm not realy sure if I should worry about it or not, and thanks CJ, i'll check and make sure there all in right
Quote by dcdossett65
Life is too short to worry about this crap.

Who.

Cares.
#9
the one i HAD started to make a serious buzzing about 3 days after i purchased it. called peavey customer support and the over the phone diagnosis from the tech support was bad power tubes. whether or not that was the case i returned it to guitar center they offered to replace the tubes but i chose my money back. you might call peavey customer support and talk with them.
#11
Well, I have several guitars, and i get the sound regardless of which one i play
Quote by dcdossett65
Life is too short to worry about this crap.

Who.

Cares.
#12
you stated the problem in the first sentence. Its a Valveking.
Quote by Sid McCall
Yeah, they don't arrest/ticket hobos because they can't pay the fines. Then they hang out in the jail all day eating free food. There's no point.


Quote by Brendan.Clace
Oh god...this thread....it is going places....
#14
My Fender Pro Jr makes a weird crackling noise that builds up until the amp makes a loud pop. Not sure what it is. If I turn the amp off and back on while it's crackling then it's fine for a while.
#15
Quote by 311ZOSOVHJH
yeah. that NEVER happens to other tube amps.

um.



shhhhh. he doesnt know that yet
Quote by Sid McCall
Yeah, they don't arrest/ticket hobos because they can't pay the fines. Then they hang out in the jail all day eating free food. There's no point.


Quote by Brendan.Clace
Oh god...this thread....it is going places....
#16
You spelled Weird wrong.


It might be a bad fuse, or something has come lose.
GEAR
Epiphone SG-400
Marshall 1987 JCM-800 2210 100W

Proud Member of:
The SG Owners Unite
Marshall Amplification
EHX Users Guild

The True Eccentric Tea Drinking Appreciation Preservation Society