#1
Just bought 2 Dimarzio Humbuckers and a Dimarzio Single Coil for my RG, and I've put them in and they're not working. It just makes a very loud buzzing sound, as if the cable from the amp isnt going into anything. Here's a picture of the wiring inside the guitar, can anyone see what's wrong?


Ibanez RG1550 with Bareknuckle Nailbombs and Mothers Milk
1976 Gibson SG Standard
Peavey 6505
Framus 2x12 (V30s)


#3
How is it grounded wrong? Like where it is supposed to go I mean (The ground wire is the one with the black tape on I think).

Ibanez RG1550 with Bareknuckle Nailbombs and Mothers Milk
1976 Gibson SG Standard
Peavey 6505
Framus 2x12 (V30s)


#4
bump

Ibanez RG1550 with Bareknuckle Nailbombs and Mothers Milk
1976 Gibson SG Standard
Peavey 6505
Framus 2x12 (V30s)


#6
Firstly i think you should try downsizing your pics before you upload them, you don't get any more detail and it just makes it more difficult to see the big picture.

As for the pickup, it looks to me like you've messed with the pots. This is bad because on guitars with more than one pickup to 1 volume control, the volume goes after the switch. So you should have only needed to mess with the wiring before the switch. Looking at that pot it seems to me that your problem was either you wired it wrong or you burned the pot out, how long did you have the soldering iron on the pot for?
EH


"Show me war; show me pestilence; show me the blood-red hands of retribution..."
#7
Just try unsoldering everything, then redo it very carefully because those connections do not look to good and they wil probably break later on.
#8
I've just noticed that there is no ground wire to the bridge. I took it out when I switched to blackouts cos they were active, but now Im back to passive I need it again right? Would this explain why it just hums when its plugged in? (sounds as if the cables not going into anything from amp)

Ibanez RG1550 with Bareknuckle Nailbombs and Mothers Milk
1976 Gibson SG Standard
Peavey 6505
Framus 2x12 (V30s)


#10
Your switch isn't wired correctly. (I'm surprised nobody spotted that)

If the lug on the very left is number 1 and the one on the very right is 8 then this is how it should be.

1 Bridge hot (red)
2 Middle hot (typically this is either white, red, or yellow but it looks like you are using black which probably means your middle pickup is out of phase)
3 Neck hot (red)
4 White wire that connects to hot on tone pot
5 empty
6 center tap from bridge (black and white)
7 black wire that grounds to back of volume pot
8 Center tap from neck (black and white)

All the green and bare wires should be grounded to the back of your volume pot as well as the ground wire from your middle pickup.
Not taking any online orders.