#1
My dad gave me a CRATE Retrofex digital effects amp and its only been played twice by my dad when he bought it, so it's basicly brand new.
When I plug my guitar into it, and turn it on, it makes this white noise kinda ****.
Even with all the knobs turned to zero, all effects off and all volume and tone on my guitar off... so i'm wondering, what the hell?
Does anyone know what could be wrong?

Any help appreciated. x_X
Quote by J.Bass.M

I don't care about the f***ing radius of the f***ing inlay.
#2
what guitar are you playing?
Out here you've gotta know where your towel is!
#3
An Epiphone special plus.
Quote by J.Bass.M

I don't care about the f***ing radius of the f***ing inlay.
#4
Does the noise get louder when you turn the amp volume up? Did the noise start when you plugged your guitar in or did it do it with no cable in the input of the amp?
#5
are u plugged into the headphone jack or line-out or something? longshot, but i figured i should throw it out there
Paul Reed Smith CE22
Fender Spalted Maple HH Tele
Epiphone Les Paul Standard
Korg Pitchblack
Boss GE-8 Graphic EQ
Dunlop ZW Wah
BBE Two Timer
Mesa/Boogie Mark IV Combo
Mesa/Boogie Rectifier 212

www.myspace.com/shapesofgrey
#6
Quote by gregs1020
Does the noise get louder when you turn the amp volume up? Did the noise start when you plugged your guitar in or did it do it with no cable in the input of the amp?

It stops when the cord is unplugged. I know it's not the cord cause i just got a brand-new one and it still does it. I know it's not the guitar because it works with my fender frontman amp so... :P
Quote by J.Bass.M

I don't care about the f***ing radius of the f***ing inlay.
#7
OK does it get louder when you turn up the amp's volume? And is it loud or just sorta faint in the background compared to the guitar?
#8
Quote by gregs1020
OK does it get louder when you turn up the amp's volume? And is it loud or just sorta faint in the background compared to the guitar?

Yes, and it's loud a ****.
I mean there's a 6yr warranty on it, only been a year since purchase if even that so I can go down to guitar center(i live in mississippi and it's in downtown memphis)so i can get it fixed soon, i just wanted to know the problem.
Quote by J.Bass.M

I don't care about the f***ing radius of the f***ing inlay.
#9
It stops when the chord is unplugged makes me think it's potentially the input jack. But it could be a lot of things with a SS amp, even an almost new one. Any type of amp has lemons. The good news is the warranty, potentially they may just send you another amp. It happens from time to time depending on the amp. Certainly take it back to where he bought it with the receipt so you can get things sorted out.
#10
Yeah, that's what i figured was wrong, the input jack. Thanks mate, imma get my mom to take me their this week. I need it fixed.
Quote by J.Bass.M

I don't care about the f***ing radius of the f***ing inlay.