#1
could someone help me with this? Yesterday i bought a 333 xl head and cab and it worked great for one night and now the tubes or something dont seem to work. I can turn the power and standby switches on but the tubes dont light up and i cant get any sound. Ive let them "warm up" for more than 15 minutes and i still dont get anything. It was there floor model so that could be the problem. thx
#2
Is the volume on the head on?
Do you have a speaker cable connecting the head to the cab? - if so is the cable good or has it crapped out on you before?
Is the volume on your guitar on?
Is your guitar plugged into the amp?
Is the cable running from your guitar to your amp good or has it crapped out on you?

I know these sound like stupid questions but there have been times when I wasn't really thinking and have had the volume off or something and thought "Why the hell isn't this thing working!?"
#3
Quote by i_am_metalhead
Is the volume on the head on?
Do you have a speaker cable connecting the head to the cab? - if so is the cable good or has it crapped out on you before?
Is the volume on your guitar on?
Is your guitar plugged into the amp?
Is the cable running from your guitar to your amp good or has it crapped out on you?

I know these sound like stupid questions but there have been times when I wasn't really thinking and have had the volume off or something and thought "Why the hell isn't this thing working!?"



Hehe, i went for rehersal with my band in a studio and i forgot to switch on the standby for the tubes and i was wondering WTF??!!!Wheres the sound??!!
#4
tubes might need to be replaced if they are not lighting up as you said
i'd bring it back to them and have them check it out. hopefully its just the tubes.
'92 Mesa Dual Rectifier Blackface
Peavey 5150 II half stack
'94 Mesa Dual Rect.
Bugera 6262-212
'93 Custom Fender Strat
Schecter C1 custom
Fender FMT Telecaster
Mosrite JR Model
MXR Smart Gate


Member of the Bugera Users Militia
#5
checked the fuse?

Kramer Focus 3000
Ibanez ATK300
Rocktron Chameleon
Digitech IPS33B
Ibanez WH10
Korg Pitchblack
Line6 UX2
#6
Quote by helsinki_vampir
checked the fuse?



ahhh yeah. i forgot to mention that to
'92 Mesa Dual Rectifier Blackface
Peavey 5150 II half stack
'94 Mesa Dual Rect.
Bugera 6262-212
'93 Custom Fender Strat
Schecter C1 custom
Fender FMT Telecaster
Mosrite JR Model
MXR Smart Gate


Member of the Bugera Users Militia
#7
Buying a floor model Bugera = fail.
MARSHALL JVM 210H
PEAVEY JSX
KRANK 412
MESA 412
FENDER STRATS
DIMARZIO
CELESTION
#8
And that is why I pay the peeps at samash 20bucks in cash to order a fresh one every time I buy something big.