#1
Ok so about two months ago I bought a Bugera 333XL combo amp. I've been really happy with the amp, and I think it really was the best choice for my price range.

But lately, at random intervals when I'm playing, the amp will produce a LOUD popping sound, then just produce static until I turn it off, then I have to wait thirty to forty seconds and turn it on again, and it's fine. This happens on any channel, with any guitar, at any distance, and at any volume. I've even lugged the thing around my house to use different electric outlets. I have no idea what's wrong, and Bugeras email on their own website DOESN'T WORK. That's right, it DOES NOT WORK. So I called Sam Ash and of course they're warranty is only 45 days, so they can't help me.

So now I'm really screwed, does any one have any guess as to how I could fix this? I sent an email to Berhinger or however it's spelled and that should be responded to by tomorrow. But I'm really in a bind, if I don't get it fixed then it's worthless, I'll have no amp to play with in Jazz band, and I don't have enough money to get any of the other amps I would ever want to upgrade to.

Ugh this situation really sucks
#5
Thanks for the worthless posts guys. Alright TS are all your tubes lighting up? It might be a tube problem. As my amp used to make loud popping noises and it turned out to be faulty tubes in it, also teh bugera stock tubes are just crap. So its best to just replace them anyways.
Guitar: Ibanez Rg 2ex2/ with Dizmarzio Super Distortion
Amp: Peavey Valveking 212 (replacing soon)
Pedals: Planet Waves Tuner, Boss DS-1, Digitech DF-7, MXR-108 EQ
#6
Quote by yocomobebes
Thanks for the worthless posts guys. Alright TS are all your tubes lighting up? It might be a tube problem. As my amp used to make loud popping noises and it turned out to be faulty tubes in it, also teh bugera stock tubes are just crap. So its best to just replace them anyways.


Agreed. Maybe there's a problem with the fuse? I was under the impression that bugera provided a 2 year warranty for these things.
I don't give a shit if you listen to me or not
#7
Yeah my tubes light up. So idk what it is, but I just received the email saying I was under warranty so if I provide them with a **** load of info they'll give me a return code thing-a-ma-do-dad to get it replaced for free.

So I'm happy now , I can get a new guitar and not buy another amp, although I think ASAP after I get a guitar I'm ditching the thing for a Mesa triple Recto or a Marshall 2203kk half stack, but that'll be awhile lol.
#9
Quote by Irnmaiden4life
should have gotten a Spider III


? I've played them and they suck. They got nice thick overdrive, but seriously it's nothing great at all.
"(Monster cable)....oh they're durable. You can
tie up people with it
"

- Slash
#10
Quote by Irocknroll1990
? I've played them and they suck. They got nice thick overdrive, but seriously it's nothing great at all.


Dude... he was being sarcastic.
#11
Quote by JimPlaysGuitar
Maybe it's a Bugera and it's carp.



aww nice way to jump on the bugera hate wagon.
GEAR:
Schecter C-1 Plus (Emg 81/85)
ESP/LTD Viper 400
Bugera 6262 Head
Marshall 1960A Cab
Bad Monkey OD
ISP Decimator
#12
Well to everyone saying aw you should've gotten X, it was either the Bugera, or a Marshall/Mesa halfstack, and if I would've picked that

1. I'd still be playing my 15w
2. I wouldn't have an amp for Jazz band
3. I wouldn't be able to afford another guitar for a LONG time. I'm a student, and to save up $3,000 would've taken me years.
#13
Quote by Ryohazuki
aww nice way to jump on the bugera hate wagon.
Nice way to jump on the "Random Wagon" wagon. It seems whenever someone doesn't like something here, they're on some kind of "wagon". It's not an opinion, it's a fact. All they ever do is leave a lot of excited kiddies disappointed.
These go to eleven...
#14
either way - he just wanted some help.

either way - welcome back as i have not seen you in about 32 days.

either way - sometimes we buy what we can as opposed to waiting as playing somethings helps the learning process along more than worthless posting...imo