#1
Ok, my Amp seems to be seriously screwed up, so i plug it in, (ive got a legacy LE10D, SD-1 overdrive)and i can here anything even on full volume, there's more or less no sound, if i use it with the Boss pedal you can kind of here it but unless its on full gain, you don't hear any distortion, and there's heaps of feedback.

so is it worth getting it fixed? is there anything i can do to fix it myself? dropping it and kicking it hasn't helped lol , id like to buy a new one but im a poor kid with out a job, and my parents are real stingy so they wont buy me a new one. what should i do?

I just looked at this
http://cgi.ebay.com.au/Peavey-Guitar-Amplifier-Studio-Pro-112_W0QQitemZ200248988528QQihZ010QQcategoryZ58718QQssPageNameZWDVWQQrdZ1QQcmdZViewItem
would it be worth bidding on? and is it likely to go up in price much more?, ive actually got $200 something on my card
return 0;

Quote by jsync
And I've eaten at some of Australia's best pizzerias.



SOUNDCLOUD
. com / fancy-elle
Last edited by Julz127 at Sep 1, 2008,
#2
go to guitar gear and accessories they will help you out
^Note: Probably sarcastic
Gear
Schecter Blackjack C1-FR
Few Agile 8-strings
Ormsby Hypemachine 2014 otw!!

Carvin X-100B
axe-fx II

W.A musicians FTW
Quote by crisisinheaven
Deep*Kick. You have destroyed every concept of life I've ever had.
#3
ok thanks, can i delete this thread?
return 0;

Quote by jsync
And I've eaten at some of Australia's best pizzerias.



SOUNDCLOUD
. com / fancy-elle
Last edited by Julz127 at Sep 1, 2008,