#1
i got an ehx eglish muff'n from karol recently

i plugged it in an the led was on saying it was in true bypass mode

then when i step on the swtich the upper led would blink but not stay on and the sound doesnt change

idk what to do ive changed the tubes, used diff cables diff guitars etc and nothing works


thing im in usa and it came with a euro adapter so i bought a little converter thingy and my only guess is that the problem is the adapter or the pedal is fried. any clues?

07 Fender American Deluxe Strat
07 Fender Custom Telecaster
09 Seymour Duncan Pickup Booster
09 Fulltone OCD V.4
10 Ibanez WH-10 V.2
09 Splawn SuperStock
10 Jet City JCA-20
97 Fender Hot Rod Deluxe

Yeh the SICK! bit sounds a bit stupid.

#2
bump

07 Fender American Deluxe Strat
07 Fender Custom Telecaster
09 Seymour Duncan Pickup Booster
09 Fulltone OCD V.4
10 Ibanez WH-10 V.2
09 Splawn SuperStock
10 Jet City JCA-20
97 Fender Hot Rod Deluxe

Yeh the SICK! bit sounds a bit stupid.

#3
without knowing anything else the first thing that jumped out at me was the power converter 'thingy'

was it a cheap one?

does it work otherwise, outside of the flashing light bumpy?



PS. OK reread - so no sound change when pressed? Battery? Faulty switch? Cheap adapter isn't powering pedal properly? Take battery out and try with just power and vica versa.
#4
unfortunately there was no battery storage thing. im gonna try the power adapter with other stuff

07 Fender American Deluxe Strat
07 Fender Custom Telecaster
09 Seymour Duncan Pickup Booster
09 Fulltone OCD V.4
10 Ibanez WH-10 V.2
09 Splawn SuperStock
10 Jet City JCA-20
97 Fender Hot Rod Deluxe

Yeh the SICK! bit sounds a bit stupid.