#1
I just got my new Peavey Vypyr 75 today. The box UPS delivered it in had the crap beat out of it... holes punched in it and everything. The amp itself hums all the time. If a guitar is plugged in or not. If the amp is set to a clean tweed model with all the gains, master level, and power sponge turned all the way down, it still hums.

I'm just curious if this is normal, or if the amp is defective, or if perhaps the rough treatment received by UPS has upset it.
#2
Probabaly defective because they're great amps and I loved it at GC, but idk...
Quote by Le_Bunny
Money doesn't fuel good music. Passion does.

#3
tighten screws tinker with it a little, then if still problem, email peavey and get a new one
My Gear
-Dean ML Xt w/ Dimebuckers+Pearlygates. Tune-o-matic bridge
-Amp: Vypyr 75
style: Thrash,Melodic Death, Metalcore, Neoclassical Dark Wave,
#4
ask for a refund. even if the amp hums by itself, it shouldnt be so beaten
GRUPO EN ESPAÑOL

SI BUSCAS BANDA EN LATINOAMERICA O ESPAÑA, ENTRA AQUI
#5
Should NOT hum. Mine is dead ISP Decimator silent. Get an exchange asap. Sorry 'bout that. I hate UPS.
#6
Thank you for all the super helpful and friendly replies . I'm asking Musician's Friend about an exchange right now.
#7
holes punched in the amp or in the box it came in?

your thread title should have read 'crappy UPS service' so more would read it.

the more effects and features and stuff a solid state amp has the more the chance of a connector or chip or something coming loose.

Def exchange. Sorry to hear that.
#8
Quote by 311ZOSOVHJH
holes punched in the amp or in the box it came in?

your thread title should have read 'crappy UPS service' so more would read it.

the more effects and features and stuff a solid state amp has the more the chance of a connector or chip or something coming loose.

Def exchange. Sorry to hear that.


Actually, the amp is just a computer, power amp, and a 12" Blue Marvel speaker. There isn't hardly anything in there really. Not a lot of dangling wires you can see. It's open back also.
#10
Are you sure the amp isn't next to a computer monitor or fluorescent light, etc?
#11
Yes I'm sure. I even tried the amp in multiple rooms all with the same effect. But I've been given a return label I need to print out, so tomorrow the amp is back on its way for an exchange .