#1
My guitar lead doesnt work unless i double it over at the end. Presuming either the wire inside has deteriorated or solder has come loose at ends. If its the first option. Is it worth repairing, or chuck it and get a new one?

Could this explain poor power to my toneport and why sustain and pinch harmonic levels have dropped?

Any links for fixing would be appreciated.
#2
It has definitely come loose at the ends.
You can fix it yourself if you have a soldering iron, and probably make it better than when you bought it! It's very simple to do, as there are only two wires (a shielded signal wire, and a ground). Just make sure the connections are true, and that the signal doesn't comein contact with the ground.

Quote by emad
jthm_guitarist
Warned for trolling!


Quote by metal4eva_22
Didn't you say that you had a stuffed fox that you would occasionally fuck?

Quote by Axelfox
It's not a fox,it's a wolf.
#3
if its a fairly long cable then just to be safe you might want to cut 6 inches to a foot off each end just to make sure the cables not broken itself.
#4
Yeh, sounds like a solder/connection problem, same ****ing thing happened with my 30 foot Monster Cable, lifetime reliability my ass! Patched up with the soldering iron 3 times and it still came undone.
Quote by dannyniceboy
I consider myself to be really intelligent and I've gotten into a fight coz this kid thought it was nasty to put sour cream on enchiladas.


Quote by Minkaro
The fact that I went TOO high singing a Darkness song on Singstar


DARK RED TEAM
#5
yeah thanks all, should have checked as after i posted i took it apart and sure enough, solder. dont have solder iron though. may have to buy one.
#6
yeah, they are pretty cheap and easy to obtian. good luck.
Quote by dannyniceboy
I consider myself to be really intelligent and I've gotten into a fight coz this kid thought it was nasty to put sour cream on enchiladas.


Quote by Minkaro
The fact that I went TOO high singing a Darkness song on Singstar


DARK RED TEAM