#1
I have a Randall RX120DHS (it's a solid state half stack) and I was playing and all of the sudden it just stopped. I can turn it on and off but there is no volume and the volume on my guitar and amp are both up... I thought the instrument cable was bad but I switched and it still won't play... What could be wrong?
#2
maybe a bit of circuitry blew?
Quote by SlayedInTheFace
I would wank over all of you if I was a gay paedophile who liked simultanous gay wanking
#5
Quote by saberrocks
Maybe one of your tubes broke down


in a solid state amp? oooook professor.

PS = This is why I don't buy cheap gear
#6
its do with the amp tempreture. Ive had this problem a few times, if you take an amp from a place thats a certain temp, and put it to somewhere thats totally different, it tends to not work, or switch on - be fine for a bit then likes to die. So just leave it in a room for like 10 mins, let it climatise, then try it again, if that doesnt work, then you know its something wrong with the amp circuitry or something.
#8
Quote by mrbungle50221
maybe a bit of circuitry blew?


how do I tell if this happened and what do I need to do to fix it?
#9
Quote by SenorSmiley
in a solid state amp? oooook professor.

PS = This is why I don't buy cheap gear


lol sorry I can't afford it.. I'd love to have a nice tube amp
#10
Quote by Anthony1991
its do with the amp tempreture. Ive had this problem a few times, if you take an amp from a place thats a certain temp, and put it to somewhere thats totally different, it tends to not work, or switch on - be fine for a bit then likes to die. So just leave it in a room for like 10 mins, let it climatise, then try it again, if that doesnt work, then you know its something wrong with the amp circuitry or something.


I didn't move my amp at all though.. it's been in my garage and it just cut off while I was playing
#11
Quote by mrbungle50221
maybe a bit of circuitry blew?

that.
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#12
Quote by kirkhammett09
how do I tell if this happened and what do I need to do to fix it?

did it just die or was there a noise first? did it seem unnaturally hot? do the lights etc come on when you switch it on?
Quote by SlayedInTheFace
I would wank over all of you if I was a gay paedophile who liked simultanous gay wanking
#13
Quote by oneblackened
that.


so just take it to some guitar shop and let them look at it and fix it? or will it be super expensive?
#14
Quote by mrbungle50221
did it just die or was there a noise first? did it seem unnaturally hot? do the lights etc come on when you switch it on?


There was no noise, it just died; the power didn't even cut off, the volume just cut off. It didn't seem hot and yes, the lights still come on like everything is fine. I hope it's a cable or something instead of my head messed up.
#15
solid states are INSANELY expensive to fix, and usually aren't worth it.
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#16
Quote by oneblackened
solid states are INSANELY expensive to fix, and usually aren't worth it.


:/ that sucks...
#17
Quote by kirkhammett09
There was no noise, it just died; the power didn't even cut off, the volume just cut off. It didn't seem hot and yes, the lights still come on like everything is fine. I hope it's a cable or something instead of my head messed up.

i dont think something blew then, cos then nothing would work cos the circuit would be broken, it might just be a connection, or your cab/speaker went and the head is fine
Quote by SlayedInTheFace
I would wank over all of you if I was a gay paedophile who liked simultanous gay wanking
#18
Quote by mrbungle50221
i dont think something blew then, cos then nothing would work cos the circuit would be broken, it might just be a connection, or your cab/speaker went and the head is fine


i think it may be the cable going from my cab to my head .. theres a little tear it and it's white
#19
Is there a fuse you could check?

Do you have it plugged into a power strip? Try a different outlet

Does the amp have a headphone out? Is that working?

Try a different guitar and different cable.

Unplug all stompboxes/effects and see if that helps
#20
Quote by SenorSmiley
Is there a fuse you could check?

Do you have it plugged into a power strip? Try a different outlet

Does the amp have a headphone out? Is that working?

Try a different guitar and different cable.

Unplug all stompboxes/effects and see if that helps

do this, BEFORE you take it in.
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#21
Quote by kirkhammett09
i think it may be the cable going from my cab to my head .. theres a little tear it and it's white

thats it then, im pretty sure nothing has blown in the head at least cos its still turning on and all the lights are working
Quote by SlayedInTheFace
I would wank over all of you if I was a gay paedophile who liked simultanous gay wanking
#22
Amps can have all the lights on and still not work. If plugging the guitar direct with a good cable doesnt work then theres a good chance something inside gave out. If the lights are on then its not going to be a fuse. The problem with SS stuff is it can be anything. A cap, resistor, transistor or the transformer. Taking it to a shop could get real expensive real fast trying to figure it out.
#23
Quote by SenorSmiley
Is there a fuse you could check?

Do you have it plugged into a power strip? Try a different outlet

Does the amp have a headphone out? Is that working?

Try a different guitar and different cable.

Unplug all stompboxes/effects and see if that helps


cool ty... I believe some of the wires or something came loose inside the cabinet because it works fine using headphones... thanks!
#26
it could also be something in the output stage that comes after the headphone amp - at least if you need to get it fixed you can tell them that and save some time.
#27
yeah, I have to agree with SenorSmiley on this.
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#29
Quote by willwelsh816
is it plugged in?

Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.
#31
srsly?
Current Gear:
LTD MH-400 with Gotoh GE1996T (EMG 85/60)
PRS SE Custom 24 (Suhr SSH+/SSV)
Ibanez RG3120 Prestige (Dimarzio Titans)
Squier Vintage Modified 70s Jazz V
Audient iD22 interface
Peavey Revalver 4, UAD Friedman BE100/DS40
Adam S3A monitors
Quote by Anonden
You CAN play anything with anything....but some guitars sound right for some things, and not for others. Single coils sound retarded for metal, though those who are apeshit about harpsichord probably beg to differ.