#1
Had it for about 6 months and suddenly it's starting to sound really weak and muffled. Today when I switched it on it was even more noticable than before. Is this a common sign of the valves dying? Or perhaps something else?
We're System of a Down and whether you wanna F**K OR YOU WANNA SUCK!! THEY'RE GONNA KILL US!!!11~~~~
#2
It MIGHT be a little too early for the tubes to be dying unless you've been playing it a lot at high volume, or not really been nice to the tubes. But that's how mine started to get when the tubes went back. The volume would swell and then die, and the amp hissed like crazy.
Winner of the 2011 Virginia Guitar Festival

Protools HD
Lynx Aurora 16/HD192
Mojave, Sennheiser, AKG, EV etc mics
Focusrite ISA828 pres
Waves Mercury
Random Rack Gear

65 Deluxe Reverb
PRS CE 22
American Standard Strat
Taylor 712
#3
Quote by Artemis Entreri
It MIGHT be a little too early for the tubes to be dying unless you've been playing it a lot at high volume, or not really been nice to the tubes. But that's how mine started to get when the tubes went back. The volume would swell and then die, and the amp hissed like crazy.


It does seem too early for the tubes to be buggered especially since I rarely play loudly and I have treated it well. Not to mention the clean channel is unaffected as I've just realised so I'm clueless as to what it may be.
We're System of a Down and whether you wanna F**K OR YOU WANNA SUCK!! THEY'RE GONNA KILL US!!!11~~~~
#6
Sounds like tubes to me.... It is a bit early but it could just be one tube going out effecting the rest. Change out the preamps first see what happens then move on to the power tubes. Other then that it could be your just getting used to the amp so it sounds weaker to you or maybe the speaker finally broke in and so on.. Theres countless answers without us playing it for 6 months its and knowing the amp its just educated guess's....
#7
If it's just the clean channel (plus your volume is about the same, just weak and muffled tone) then I'm guessing preamp tubes. I believe it's common that some tubes are only used by the lead channel.
Quote by Lunchbox362
This thread if fail in almost every way imaniganable.