#1
It won't load my videos! Is anyone else having this problem?

It also, when I do get to the uploading, no percentage tells me how long it's gonan take. Any help??( I'd ask the youtube forum if there wasnt some wierd joining process)
meh
#3
check out my channel bteww
GEAR

ESP LTD F-155 DX BASS
Epiphone Thunderbird bass
Samic cr1 bt bass

Dunlop bass crybaby
Ibanez PD7 Bass Overdrive Pedal
Boss bass chorus
Zoom 607 multy effects pedal

Ashdown 180 watt bass amp
Mega 30 watt

METAL UP 'UR ASSS
#5
honestly who cares. its youtube.
98% of teens have been around or have had alcohol. Put this in your sig if you like bagels.
Quote by blackflag49
Joe Biden's wife is a total cougar.


Quote by imdeth
metaldud damn it I said ignore the penis!

XBL Gamer Tag:

Arch Enemy65
#6
Youtube says I have a new message, but it won't show it in my inbox >
Curse you, bloody video sharing website!
Hold the Heathen hammer high!
#7
I hate all of these YouTube issues.

What ever happened to the year 2007? When the site was still simple and user-friendly?

I swear, that's what sucks about the internet, they take great websites, make them complicated as hell, and rape them up the ass.

That's why I love UG. No new idiotic changes.

/my random interwebz rant
#8
Do you have the required items installed to play the video?

Also, check your internet speed - it might be too low.
My Last.fm
USA Fender Stratocaster | Roland Cube 60 | VOX ToneLab LE
#9
Quote by Iriathz
Do you have the required items installed to play the video?

Also, check your internet speed - it might be too low.



I'll clean my computer.
meh